Depnotify after erase all content and settings


Not sure if anyone has run into this slight issue... when I erase a new M1 iMac using Erase all content and settings, and then enrol a managed device, when the enrolment completes I run additional installations and configuration via DEPNotify. DEPNotify does not kick in when the computer is wiped using Erase all content and settings, however if I use Recovery and wipe it, everything works as expected... 


Valued Contributor II

One thing you might want to try is flushing the policy log of the Mac you did an Erase all content and settings on. Wiping from the device side of things won't clear that.

Thanks for that suggestion will definitely try it out however I also took stock of new iMacs which displayed similar issue but worked once wiped via recovery.

We have never had a good experience with leaving the record in jamf then enrolling again. Our solution is:

  • Erase all content and settings or what ever method to get the device to brand new out of box experience.
  • Remove the device from jamf.
  • Enroll device into jamf

This had given us a 100% success rate for pulling down enrollment policy and configuration profiles when re-issuing devices.