Filevault Recovery key is missing

Asifahmed
New Contributor II

Hell Team,

 

I am looking for a solutions to get the recovery key in my JAMF console for those mac devices recovery key is missing, but user should be interrupted. I can see it has happened for both personal and institutional key. What is the main concept of personal recovery key validation, some time it is showing invalid or unknown but recovery key is there, strange! Please help to understand and also with a perfect resolution I am looking for. BTW device is getting encrypted by a config profile and to escrow the key in JAMF.

9 REPLIES 9

PhillyPhoto
Contributor III

I use a modified version of this script and it's been helpful for us

https://github.com/homebysix/jss-filevault-reissue/blob/main/reissue_filevault_recovery_key.sh

But this script will run on Big Sur and Monterey OS?

And is it not possible to escrow without any user's prompt? I mean full silent operation.

When you say 'modified', in what way? We are also using this script but are running into some issues with Big Sur/Monterey where the key is not being picked up.

We're also seeing some machines that have had new FV recovery keys (PRK) issued followed by a recon, which does update it in Jamf. Fast forward a week or so and those same machines are back on the list of "unknown" with some of them not having the key available once again while others just have the status of "unknown". 

Seeing the same exact thing @BradJr, but it only takes a few days or so. Something is up. And it is becoming "Unknown". I have reached out to Frederick, Traveling Tech Guy...

Any luck finding a solution? We've been seeing this this for some of the computers in our environment, too...

Still nothing that I've seen or heard of yet. Seems like there is definitely something up but perhaps we'll see some of a resolve as we begin upgrading to Ventura.

Not sure if anyone else has seen the same issue on any Ventura machines yet?

jklimeck-ahead
New Contributor

Some say a reboot makes Valid stick. Run the PRK Re-issue policy again, user enter password, but this time the Mac reboots. So a reboot somehow makes "Vaild" stick...This seems to be working on some of the Macs / users that I have worked with...