Anyone seen "Unable to Create an Invitation"

jeremy_spolande
New Contributor

On building, in 9.0, on an existing and new account, administartor, then custom all priviledges.

37 REPLIES 37

rwwest7
New Contributor

We are getting the error also. Anyone figure it out yet?

Matt
Valued Contributor

I just had this happen to me as well using 9.0.1 and Casper Imaging.

jeremy_spolande
New Contributor

I think ours was a false permissions error brought on by the jss being out of disk space, Would also check the account you are using to build has the right privilidges as a first step.

NoahRJ
Contributor II

Just saw this in our Casper Imaging, too. Quitting and relaunching the application seemed to fix it, but still a little mystified as to why we got hit with it in the first place. Already double-checked that our imaging account has proper privileges.

charles_hitch
Contributor II

Did anyone find the cause or a fix for this? It just started happening for our systems. Admittedly I was making changes for access control, but I am still getting this error when I am using an account with all privileges (Administrator privilege set).

NoahRJ
Contributor II

I'm now seeing it repeatedly when I assign Site access to an account. Users get hit with that error anytime they try to image with a configuration. If I don't select a config and Casper Imaging sets the name and fixes the ByHost files, then I'm able to image without a hitch. Is there any way to assign permissions to different imaging configurations to allow all users in all Sites access?

ahanley
New Contributor II
New Contributor II

Anyone find a solution to this yet? I am seeing this same error when trying to image a machine on my first version 9 (9.12) JSS.

NoahRJ
Contributor II

Looks to have been fixed (for me, at least) in 9.2.

Joel_Peasley
Contributor

Hey all,

Just a quick note to let you know that we are aware of this issue. We are currently are seeing this issue when using Netboot with a user that is a member of a LDAP Group and that LDAP group is added into the JSS. If you are seeing this issue please contact your Account Manger to discuss workarounds for this issue. If this doesn't seem to match the how/where/when you are seeing this issue please contact your Account Manager to further troubleshoot this issue. You can reference this issue with D-005557 in the release notes of future releases for the Casper Suite.

Thanks,
Joel

Matt
Valued Contributor

Emailing TIm right now!!!!!!!!!! Thanks Joel.

jwojda
Valued Contributor II

it's a permissions issue, we had it, and we had to change the permissions for the user/group we were using, it was something semi-convoluted that we had to grant create permissions on...

I'd look them up, but my own jss is down at the moment

Matt
Valued Contributor

JSS Objects:
Computer Enrollment Invitations All
Computers All but Delete
Enrollment Profiles All
Mobile Device Enrollment Profiles All
Mobile Devices All but Delete

Recon: Both of them checked

Casper Imaging:
Use Casper Imaging

benyoung
New Contributor

After the upgrade to JSS v9.2 had this notification and was resolved but making a fixed account have Access Level "Full Access" and Privilege Set to "Administrator". Not ideal, so will be looking through these posts to try identify what could be the cause. Will also email our channel rep quoting D-005557 for any possibles answers.

jhalvorson
Valued Contributor

We are seeing this error while using Casper Imaging 9.21 with the JSS running 9.21.

The tech can log into Casper Imaging, but when they press the "Install" button, the error appears.

Because of other related permission errors with Casper Remote, I had been setting each account Privilege Set to Administrator, then back to Custom and reducing to what I thought was needed. What I need is a Privilege set just for techs that image Macs, or a better understanding of each and every privilege.

The short term and very undesirable solution has been to set the Privilege sets to Administrator.

jwojda
Valued Contributor II

@jhalvorson here's a youtube vid of ours. http://youtu.be/S9ClvIihMxg

jhalvorson
Valued Contributor

@jwojda Thanks. Our configuration center is back in the imaging business again. 🙂

thanzig
New Contributor II

I just ran into this as well. I opened up Casper Imaging preferences on my netboot and noticed "Allow untrusted SSL" was not checked. I checked it and then the error went away.

JimAllsop
New Contributor

Had this issue this week. My help desk techs ldap account would give that error. Had our systems guy give him AD domain admin priv. Again and it went away. Our systems team took away all my teams AD admin privileges so I made standard user accounts in JSS and that problem went away.

thanzig
New Contributor II

I was getting this issue on my netboot image. I trashed the 9.2.3 casper imaging app as well as the jamf preferences in the user library. I then navigated to my JSS URL in safari and viewed the certificate. I dragged it to the desktop and then double clicked it to bring up Keychain. I made sure it was installed in the Login and System keychain and changed it to always trust. I then installed the Casper Imaging 9.2.4 and now I don't get this error anymore. Before I had to always check the "Allow untrusted SSL".

apple_support1
New Contributor
Posted 10/25/13 at 7:48 AM by Matt JSS Objects: Computer Enrollment Invitations All Computers All but Delete Enrollment Profiles All Mobile Device Enrollment Profiles All Mobile Devices All but Delete Recon: Both of them checked Casper Imaging: Use Casper Imaging

Thanks Matt, Your solution fixed my problem

johnklimeck
Contributor II

Matt,

What's up dude, hope all is well.

Worked like a champ (charm)!

Thx,

jk

mmayo
New Contributor II

I was just having this same issue a few days ago and it seemed to be because my password contained symbols in it. My password contained a + and a @. I created a second account with identical permissions and used a password only containing letters and numbers and the error went away. I was able to successfully image using a non-Admin account and only giving the user the permissions as suggested by Matt.

mark_mahabir
Valued Contributor

I reproduced this in Casper Imaging v9.72 today. My (LDAP) password had a '%' in it.

I was able to successfully image using our jamfadmin account which contains no special characters, just a mixture of upper and lower case letters.

May
Contributor III

@Matt suggestion worked for me with the error below. Thanks!

f41b01cf4c31455495d1fba613e02f1d

5Y54DMIN
Contributor

What else could it be if @Matt suggestions didn't work?

lynnp
New Contributor

I'm seeing this error as well despite having complete admin access for the account I'm using.

After upgrading from 9.65 -> 9.82 we've had this issue. It's also worth noting that our NBIs are having difficulties seeing the JSS. The DNS hostname of the JSS resolves fine in the terminal, but casper imaging will not communicate with the JSS unless you enter the IP in the JSS location box. Once you connect using the IP instead of the hostname, we get this error when we try to image.

Edit: We're also using autoDMG and AutoCasperNBI for NBI creation.

curullij
Contributor

I had this issue today on 9.92
Added our jss to the hosts file of the Netboot image. Fixed it!!

alexjdale
Valued Contributor III

I had this issue today with Casper Imaging. The message appeared once when I clicked "Image." I simply re-clicked "Image" and it went through.

anickless
Contributor II

So if anyone hit this in 10.3 Support says there is a error in JSS that special characters makes this error show. If you change the account password to just numbers and letters than the issue goes away.

asedelmeyer
New Contributor

I am now seeing this issue for the first time, and we just upgraded to 10.3.

So, @anickless , Are you saying that the special character in my AD password is causing this problem? Basically, I have to change my password to not include special characters just to get Jamf imaging to work. Not cool. Anyone else have an update on this?

jamfnc
New Contributor II

We have upgraded our to Jamf Pro 10.3.0 on 6/4/2018 and using LDAP accounts to do imaging and seeing the same error due to special characters in the passwords. Work around now by using local JSS account without special characters in the password and just alphabet and numbers

Leal
New Contributor III

@jamfnc Have you heard back from support on this?

benducklow
Contributor II

Yep, special character issue popped up after we upgraded from 9.101.0 to 10.3.0. We basically relayed the workaround to our affected techs vs. creating a local JPS account. Hope this gets fixed, that a big ‘bug’!

boanes
New Contributor III

I actually just got off the phone with Jamf regarding this...

It's bug PI-005660 and is fixed in 10.4 that was just released today.

danadonaldson
New Contributor

I'm on 10.5.0 and I've got this issue...not fixed in 10.4?

benducklow
Contributor II

Should be related to a special character in the Users password..

danadonaldson
New Contributor

@benducklow Yeah, I'm assuming that too. Going to try it...but it's a big issue that I need to make my password less secure to use Jamf. Hopefully that's it. Was supposed to be fixed...