Casper Imaging not Completing Imaging Process With Casper 9.81

New Contributor

Hello Fellow JAMF Goers:

I am having a problem that I hope can easily be solved. I have a handful of iMacs and Macbooks that I am trying to Image with Casper 9.81. The imaging process for all of these computer starts off smoothly, however, once they undergo their restart during the imaging process and start installing software on the boot device after imaging, they come up to a temporary Adobe account and go no further. I have tried to restart each of them multiple times, and have even tried to restart the imaging process and the same issue occurs.

On older versions of Casper Imaging, when this occurs, once simple restart usually does the trick and then it finishes its imaging process and gives me the splash screen, but with Casper Imaging 9.81, nothing I do seems to work to get it to finish the imaging process.

I have looked at the imaging logs for each of these computers and there is nothing that stands out that would tell me what could be the cause. Frankly, I'm stumped. Has anyone else run into this same problem with Casper Imaging 9.81 at all? If so what have you done to work around this?

Any help or advice would be much appreciated!



I did.. but only when people tried imaging with Casper Imaging versions that were prior to 9.8 (at the time). Using a boot key, imaging would hang in the same place after it had been imaged using Casper Imaging 9.73 or earlier. In updating the Casper Imaging app that they used to 9.8, it started working again.

Are your images being run from an up to date version of Casper


Hey @narelmm to jump onto @yellow's response you will definitely want to make sure your JSS and version of Casper Imaging match. In my case when I upgraded to 9.81 I forgot to upgrade my Casper on my NetBoot image and although the imaging process mostly worked, the post-imaging process hung and would not finish.

Secondly, and if I'm interpreting your problem correctly, if you continue to have machines simply login with the Temp Adobe Install account and not do anything, i.e. the full screen JAMF helper screen does not appear, give this solution a try: I've implemented a similar script in my imaging workflow and reliably get the JAMF helper screen every time. Hope this helps!

Honored Contributor II
Honored Contributor II

I get this a lot, Casper imaging and JSS version mismatches are a definite problem area as the others have mentioned.

The other things to look at are the jamf.log locally on the client, which will indicate whether its actually making progress installing the packages, and the standard Mac OS install.log, if it seems to have been on a particular package for an excessive amount of time. Between the two I've usually been able to narrow down the culprit.

New Contributor III

We were experiencing the casper imaging not completing the imaging process and being stuck on the install to boot drive process after upgrading to 9.81. We were also experiencing other issues with the recovery partition. In the end, we had to rebuild the OS base images with composer 9.81 (all the OS bases were most likely built with 9.63) and remake our image configs within Casper admin 9.81. We also are creating recovery HDs with a pkg instead of using the built in feature in Composer and Casper admin configs.
Once everything was redone using 9.81 the imaging goes smoothly

New Contributor III

I'm also experiencing the same issue. However, creating a new Imaging Config within Casper Admin did not resolve my issue.. My Netboot image is OS 10.11.1 and Casper Imaging 9.81.