How to stop Bong sound 27" iMac latest quad core

Valued Contributor

I know this is not Casper issue. Anyone knows how to stop or lower the volume (very loud bong) startup sound in firmware level for good on 27" iMac latest quad core. I have tried numerous apps and terminal commands (yes they work), but as soon as I re-image the Mac it comes back like ghost. BTW this is my testing Mac and I work in a office full of people.....rather embarrassing....
Also I have plugged headphones and still no luck. Bong is loud as ever from main speakers!!?? Help will be appreciated a lot :)


Valued Contributor

As I have to send this iMac back to supplier after evaluation….perhaps I shouldn't mess about with this :) but thanks, I remember seeing refit thing before (I don't think I had guts to play with it then)

Valued Contributor

Ok holding down mute button at reboot done the job. I have re-image the iMac twice and still good :)
But still want to know what file changes to achieve this!


Sent from my iPad

Honored Contributor

That is probably flagged somewhere in EFI because the OS isn't even on or controlling the computer at that time.

Not applicable

or controlling the computer at that time.

I've heard and read that this will allow you to peek at EFI. It's really
for setting up a boot loader like environment. Never done it myself. All
I can tell you is to be careful or you could brick your box.

- JD

New Contributor

In Mac OS X 10.7.x just use the built in "nvram" command to set "SystemAudioVolume" to 0. The beautiful part is that it can be scripted to set as a shutdown script or periodic to see if it changed.

bash-3.2# nvram -p
SystemAudioVolume   0

Or for those of us who like XML:

bash-3.2# nvram -x -p
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
<plist version="1.0">

No start-up chime for me. Normally the system saves the last audio state on shutdown/reboot, but that can be changed with a shutdown script. Be sure to read the man pages or --help to ensure you are setting things correctly and don't cause a rip in the space-time continuum.

bash-3.2# nvram --help
nvram: (usage: no such option as --)
nvram [-x] [-p] [-f filename] [-d name] name[=value] ...
    -x         use XML format for printing or reading variables
               (must appear before -p or -f)
    -p         print all firmware variables
    -f         set firmware variables from a text file
    -d         delete the named variable
    -c         delete all variables
    name=value set named variable
    name       print variable