iPad Enrollment and WifI issues


Sorry for the upcoming long post but I have been pulling my hair out all week. I needed to enroll 15 iPads which are in my DEP using AC2. The WiFi profile would not stick. I needed to set a profile to connect to a hidden SSID with WEP2 which would put the device into my VLAN. It worked once or twice on an iPad but then would not work again. I started to try one at a time to see if I had the settings incorrect with the Blueprint. No luck.

I then switched to not auto enroll but created 2 blueprints. One with the WiFi Profile and Trust cert and the other with the enroll cert. That too work a few times but was not consistent at all. I kept trying to recreate the profiles and reload them, restore the iPads, starting the process over and over. I got about 8 of the 15 done. It would be a toss up to see if it worked or not. Then I went and looked at the completed iPads and they seemed to have lost the WiFi connection to the hidden SSID. It showed other open ones but not that one. Our main Wifi that the students use I can't use because it is pretty much segregated and would not be able to see my JSS. I worked with JAMF through a support ticket and pretty much came to the conclusion that something was up with my WiFi. Contacted my Network department and while they said they would look into it, I haven't heard anything.

I finally decided to try and start from the beginning again with 2 blueprints. I created the WiFi profile within AC2, download the Trust and Enrollment profile from the JSS. Made sure my devices were not within my Prestage and refreshed that and the DEP to be sure.

I applied the first Blueprint with the WiFi and Trust first. It completed well. Because it I did not use the auto enroll method, I had to agree to the Terms of Agreement and select a WiFi profile on the iPad. It still did not show my wifi profile I created. I had to connect to a test SSID that my network department had to set up for some reason. I would then see, just before it went to the next screen, my SSID would pop up. I would then have to go to WiFi settings within the iPad, select my SSID and then forget the test one. I could then go and apply the other blueprint in order to enroll the iPad.

While now I think I have finally figured it out, if I shut down the iPad completely and restart, it does not auto join my SSID. Yes I selected that in the profile creation. I have to go through the process of selecting the test SSID and then my Hidden SSID.

So after this long ass story, sorry, my question to all this is. Do you think this is a Network issue, iPad issue or a JSS issue? Or a combo there of. I am not well versed on the network side but is there a way my network admins can make my Hidden SSID be more on top of the connection chain? I know you can usually set that on a desktop machine but not sure with an iPad or if it can be controlled within the AP settings.

Thank you in advance for any suggestions.


Contributor III

Sounds very much like a network issue...

New Contributor

We have a similar issue like that as well.
Only here we have like 1000 iPads (iPad 2nd gen to iPad air 2) with ios 9.3-10.2.1 and 100 have lost the hidden SSID here.
I don't know where I have to look I've tried a lot of things, i use a lil work around here now.

Our wifi hidden SSID is pushed true our MDM configuration profile, I cloned my wifi configuration and named it (wifi name) Recovery, if a student comes to me with wifi loss, i just add them to the recovery(so it has 2 off the same wifi profiles on it) and then they see the wifi again.

If it loses after few weeks again, i just deleted them from the recovery list, and add them again, so the wifi will be restored.

That 100 iPads contains all kinds of iPads (2nd-ipad air 2 gen) they only have 1 thing similar.

I'm still testing a lot of things to look what it can be.