issue connecting to DFS share with High Sierra

New Contributor


I have a collègue who is having issue connecting to SMB/ works fine locally but when connecting via the VPN (IPsec) always gets the error "connexion failled to serveur it is possible that the server does not exist or is not available at this time ....".

This used to work before upgrading to 10.13.1

Other things that I have tried

  • used gifs instead of SMB no change
  • can be pinged
  • scanned port 139 (netbios-ssn) and 445 (microsoft-ds) seems ok
  • used the IP address instead of, does ask for username and password but after that same error.

Any suggestion on next things to look for ?



New Contributor

Hi there,

I had similar issues with High Sierra, but we are connecting to a Linux NAS. The SMB protocol is not working and we get the same error message as you described above; we found a workaround for now using AFP protocol instead of SMB, but I doubt this would work for Microsoft Windows Server.

New Contributor

Upgraded a test MacPro to High Sierra 10.13.3 and am experiencing the same SMB problems everyone was having with Finder hangs when moving or changing a folder name but, only with DFS, over SMB. Once it hangs only a restart can get the system back. Tried using cifs: but that does same thing. Looking for a fix for accessing a DFS namespace share on Windows Server.

New Contributor

High Sierra 10.13.3 is supposed to fix this issue but I have one user who is now unable to reliably connect to the server.

the fix in 10.13.2 is to edit (or create) the /etc/nsmb.conf file to:


(found this tip elsewhere on the forums here)

This worked until the user updated to 10.13.3 but now we're getting 'access to this has been denied for your account, please see your administrator' I know the account isn't locked out, as the computer's joined to the domain and the person is using their domain credentials to log on; the affected share is her network home directory. Other shares intermittently do the same thing, but sometimes they just work as expected.

I"m going through a packet capture file right now to see if anything jumps out.