JSS Actions stuck on 'sending'

New Contributor III

Sorry if this is something obvious I've missed. I tried searching through old discussions but couldn't find any with a solution to this problem

I set up a non-admin user in the JSS to be able to manage iPads but the problem we're running into is any command sent (lock, clear passcode, wipe, etc) only show 'Sending' indefinitely after pressing the button. I double-checked the permissions in the JSS settings but everything looks good. Is there anything else I could check there or somewhere else in the settings?

I logged into the JSS on the same computer with my account, but in a private browsing window and the commands went through right away for me. I tried clearing cookies and browsing history as well as using the private window for the other account but get the same issue.

The account as it stands is an LDAP account with Full Access and Custom privileges.


Contributor II

In my experience, the user has to have update rights for mobile devices. This wasn't always the case, but it is now. I discovered it in 9.97, but we only had a couple of users affected by it so it could well have been introduced earlier.

New Contributor III

Thanks bburdeaux! That seems to have done the trick. Kind of weird that attribute is separate from the actions, but it makes sense that one would need update to run the actions.