Keychain - strange - unable to reset

Contributor II

On one mac client where I register it with company portal it first prompt for user to sign-in with AD credentials. And works fine.
Then Jamf is prompting to sign in and also there user and password is accepted.

Then finally keychain is prompting for JamfAAD to add to Microsoft workplace join and there the password does not work. If the user enters and password she used for long time ago it does accept i

I have of course tried and reset keychain manually but it will simply still not accept it

Any has seen this before ? as the issue only appear on this jamfAAD and microsoft workplace join


New Contributor

I have noticed this happening recently since our mac users are now all remote. We use Active Directory/Mobile accounts. I have tried deleting the Company Portal plists/keychain entries, and it still takes the old password on jamfAAD and Microsoft workplace join only. Anyone have a fix for this?

Contributor III

I never recommend using the reset keychain tool. Instead I'd delete the contents of ~/Library/Keychains and restart the computer to make a new keychain.