MacBook Air Late 2013 netboot image?

Contributor III

Hello, I've been having a devil of a time getting a netboot image that works with the MacBook Air 13" late 2013. I've captured a OEM image from this Mac using the latest version of System Image Utility, however once the image is activated in for OS X 10.8, the MacBook Air can see the netboot, but refused to netboot.

Has anyone had success netbooting this model?

Thank you!


Contributor II

Make sure you are using the 10.8.4 build 12E3067 nothing else will boot the 2013 MacBook Air.

Contributor III

I had success booting it so far. Here's how I do it.

Capture a base image from a freshly restored Recovery Install (or whatever it is called). Save that as my base and upload it to the JSS via Casper Admin. Then I have a netboot creator workflow in the JSS that installs the OS and modifies/installs the files necessary to create my base net boot OS (apps, settings, background, etc).

I run the workflow on another machine, let it boot to the OS as there are some scripts that run at reboot. Then boot to another partition and capture it with the System Imaging app. Since I already have the base OS from the Interent Recovery in the JSS, I just made a separate worfklow for the MacBook Air's and they are booting and imaging.

Hope that helps.


Honored Contributor II
Honored Contributor II

Yes, I was able to get a working NBI off of a new MBA Late 2013. The process I used:

  1. Connect USB drive to the machine and boot into Recovery mode.
  2. Recover to a partition on the USB drive.
  3. Once recovered, boot off of the USB drive and configure the drive to be your NetBoot image. This includes the following:

  4. Setup the initial user

  5. Run all Software Updates until there are no more
  6. Enable the Root user and set the root user to automatically login
  7. Remove all un-necessary apps and utilities
  8. Add Casper Admin and Casper Imaging to the system
  9. Add dock icons for Casper Admin and Casper Imaging, along with Disk Utility and Terminal
  10. Run Casper Imaging and connect to the JSS one time
  11. Set Casper Imaging to open at login

More information can be found at this link:

Once I have the system set the way I want, I run Casper Imaging and image the machine I am connected to. This gives me the machine I will need for creating the image.

After imaging the system, I boot from the internal hard drive. I then use Terminal to delete the swap files from the USB drive, located in /private/var/vm/

After doing that, I run System Image Utility to create an NBI of the USB drive.

I've used that process for every new NBI I've needed of late, and it has worked flawlessly every time.

Legendary Contributor III

Kind of off topic, but is that actually what the new MBAs are being called? MacBook Air Late 2013? If so, I never took note of that and, Apple has a pretty funny definition of what "late" in the year means. :)

Valued Contributor

Nope; they're called Mid-2013.

Esteemed Contributor III

The latest MacTracker shows "MacBook Air (13-inch, Mid 2013)"...



Legendary Contributor III

Ok that makes me feel better. Time already moves too quickly for us to be using terms like Late 2013 just yet! Thanks Don and JP! :) :)

Contributor III

Thank you for the suggestions, I meant MBA mid-2013 not MBA Late 2013. I've been working with a Mac Mini Late 2012 on and off today and must have had that on the brain when making this post...

It's good to hear others are having success, I'll try the methods posted and report back.


we too just received a brand new shipment of MBA Mid 2013 units and they fail to netboot.
As I understand it, I have to make a new netboot image?
Has this been the norm on MBA with model changes or just isolated to Mid 2013 models?


The new MacBook Airs include Intel's Haswell processors. The custom 10.8.4 installs on the new MBAs are the only ones that include the support for it. Hence, the need to create a NetBoot set from the machines themselves.

My guess is that things will once again be unified with the 10.8.5 release. Let's hope so at least.

Contributor III

Anyone had any luck booting these with a 10.8.5 NetBoot? I assumed this would work, but have a report from someone else that an updated 10.8.5 image is not booting these machines. I don't have any on-hand to test.


I had to build a new netboot image for these Mid 2013 MBA models.
I kept my former net boot image active, so I see two when I netboot.

I have been using a Mid 2013 MBA all day, and it has 10.8.5 installed.

I just attempted to netboot it to my former netboot image, and it won't even boot to it as before.
Course, it works if I net boot to my new netboot image...that a 2013 MBA was used to create it.

Valued Contributor II

I tested a MBA 2013 with a vanilla NetInstall based on the 10.8.5 from MAS with no issues. I'm surprised it's not working for you. I'll test next week unless someone else does first.

Contributor III

10.8.5 NetBoot created and have a confirmation from the field that is it successfully booting a 2013 MBAir. Looks like the image is unified again, until Apple forks it again with new hardware.

Valued Contributor

I concur. Unified (for now).

Valued Contributor II

Yep. I built one last Friday at a client and didn't have a chance to try it on a Mid 2013 Air. Works as expected. Of course, until the new Haswell rMBP/iMacs/Mac minis are released with a custom build of 10.8.5 (or 10.9 :-(