Need help composing Umbrella Roaming Client

New Contributor II

We are now using OpenDNS and we need to distribute the Umbrella Roaming Client to all of our Mac clients. We've tried a number of times to compose a package for the installer, but we seem to be running into a few different issues:

  • Menu bar item does not always show up
  • OpenDNS/Umbrella service identifies computers by hostname, every time we create a package using Composer, the computer's hostname that is used for composing "sticks" to the package. So if we install that package on a bunch of computers, the hostname being reported to OpenDNS is the hostname of the computer on which the package was composed.

Anybody out there have experience distributing this package? Any advice on how to adjust the package so the hostname being reported to the service actually matches the hostname of the computer?

Thank you and Cheers:D


Contributor III

Unfortunately looks like most of their technical information is behind closed doors on their site. Could you give a little more info on why you cant just use their provided installer? Also, have you reached out to them for mass deployment support?

  • Are you using FEU/FUT if the package has user based preferences? (E.g. Menu bar icon)
  • The name sounds like it is hard coded in a plist/config file. You may have to dig through the package you create to see what files might be doing this. You may be able to delete them OR the permissions may be wrong and the system just simply can't update the file.

Looks like this has been out a couple years so surely they have some recommendations on how to enroll client machines in a large scale manner.

Honored Contributor III
Honored Contributor III

What format is the installer?


I'd really avoid creating composer DMG's for all but the most basic apps.

New Contributor II

Thank you both for the responses. We'll try just the basic PKG file to see what happens. The only thing bad about the basic PKG is that it comes packaged with an uninstaller and we'd rather not have the users access a tool that just disable umbrella.

New Contributor II

Hey folks,

I got in touch with the enterprise support over at OpenDNS, they have an unofficial/unsupported solution that seems to be working so far! Essentially, prior to running the installation package, you have to generate a plist with the proper ID keys embedded prior to running the installation package. So far, so good! I'll update this thread again if I run into any issues. Thank you again for the help and support!

New Contributor III

I would love more info on your workflow. We are having the same issues, and I was told by OpenDNS that they don't integrate with Casper and we had to manually install it on all of our clients or distribute it through Group Policy in AD...

New Contributor II

Has this gone anywhere? I am currently setting up Cisco Umbrella on our Macs and would like a little more information. I created a pkg. removed the uninstall from the pkg, so that clients can not uninstall it. But, has this been working for other JAMF/Casper admins?


New Contributor III

I used the Composer with the snapshot and then just added the preinstall script to the package with the 3 values (APIUserID, APIOrganizationID,APIFingerprint) that needed modifying and postinstall script (to launch application). Create a policy to deploy the package followed by forced restart. The only thing I haven't figured out yet is the "Cisco Umbrella would like to add vpn configuration" prompt. The rest looks like this:


Preinstall script:


mkdir -p "/Library/Application Support/OpenDNS Roaming Client/"
DATA='<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
<plist version="1.0">
echo "$DATA" > "/Library/Application Support/OpenDNS Roaming Client/OrgInfo.plist"
exit 0 ## Success
exit 1 ## Failure

#PostInstall script:


open -a /Applications/OpenDNS Roaming Client/

exit 0 ## Success
exit 1 ## Failure

New Contributor II

@totalyscrewedup - This preinstall script is great, I have it run right before the package install (within the same policy) and it works like a charm. I don't need to force a restart or run the post install script either since installing the package itself opens up the Menubar app.