Office 2011 and SMB Network Home Directories

Contributor II

I hope I did not miss an existing discussion on that - my apologies in advance.

After an all-mac server/client environment I got a new challenge to look after:
All file - services are on Windows2008R2. Authentication is over ActiveDirectory. The Mac home directories lie on SMB.
All my clients are 10.7.5 or 10.8.4 and are bound to the AD with Casper.

User-Library etc. are therefore on SMB - I just have sym-links to the internal harddrive for caches, fonts, movies and photos. And most of the software runs ok with that.
But I have trouble with Office 2011 - still with the new 14.3.7. Errors are "office has to rebuild the ms database", "word cannot write the", etc.
I found tips suggesting:

• using mobile network accounts
• setting up network user accounts that are defined to have home folders located at /Users/ (i.e. on your local drive).

I tried mobile network accounts and right - it works fine with mobile accounts.
But our poor network-infrastructure does not allow to use the sync-options of the mobile accounts and without that users are not happy.

About the second suggestion - how to change the mount point of the AD-user-home from /home to /Volumes/MacintoshHD/Users ?
I am afraid everybody else solves this years ago. Every hint is very welcome! Thank you very much!


Contributor III

Michael, we ran into this some time ago and had to sit down in a one on one session with our AD admins to explain and show what was happening.

Solution was to rename the 'home' directory share on the Windows server to "Home" notice the case on the "H".

On OSX there is the normal unix 'home' directory in the folder structure which is hidden, smb was getting confused with this. For some strange reason it was only affecting MS Office products.

Contributor II

dmw3, thank you very much!
ideed df shows the following on the clients for user elihmt

Filesystem 512-blocks Used Available Capacity Mounted on
/dev/disk0s2 624470624 40383968 583574656 7% /
devfs 366 366 0 100% /dev
map -hosts 0 0 0 100% /net
map auto_home 0 0 0 100% /home
map -fstab 0 0 0 100% /Network/Servers
//elihmt@ebl001a/userhomes1$/elihmt 11710443512 3235785976 8474657536 28% /home/elihmt
//elihmt@ebl001a/userhomes1$/elihmt 11710443512 3235785976 8474657536 28% /Volumes/elihmt

So the home is userhomes1$ - I will change that - probably the $ is also not good?!

How about the "empty" map auto_home?