Software cached for later installation mysteriously disappears

Richard7299
New Contributor

I ran into an issue while rolling out an Office 2004 update. I also promised myself I wouldn't send a lengthy email to the list. I have broken that promise... πŸ™‚

I wanted to send out an update to Microsoft Office 2004 to the users who have it installed on their workstations. Given that Office would likely be running when I wanted to send the update, I opted to cache the software for later installation. UPSers website 

Therefore, I set up a policy to use a set of static computer groups, because smart groups still do not work properly at our site. The policy's trigger was "Any", which would ensure it would happen as soon as possible. The policy ran on all but two of the computers in the lists, because those two computers are laptops, and are not currently able to get to the corporate network.

I then created a second policy using the same set of static computer groups. This second policy was set to trigger at logout, and would install the Office 2004 update. I sent an email to the users whose computers were in the static groups, asking them to log out and log back in at some point that was convenient for them, in order to complete the update.

On a few of the computers, I received a Policy Error executing the "Install Cached Office 2004" policy (example below):

Event log from the policy:

/usr/sbin/jamf is version 4.1 Executing Policy Install Cached Office 2004... Running OS Mac OS X 10.3.9 (7W98)... Installing cached copy of package Office 2004.dmg... Error: The package does not exist in the packages folder. Installing cached copy of package Office 2004 11.3.4 Update.dmg... Error: The package does not exist in the packages folder. Updating Inventory (Recon)...

Obviously, this was a cause for concern. I went back to check the policy log for the policy which had cached the Office 2004 update, and it had evidently been run successfully. I certainly hadn't received any errors to indicate otherwise:

Updating Inventory (Recon)... Caching package Office 2004 11.3.4 Update.dmg... Caching package Office 2004.dmg... Mounting file server JSS... Running OS Mac OS X 10.3.9 (7W98)... Executing Policy Cache Updated Office 2004... /usr/sbin/jamf is version 4.1 Unmounting file server...

So what would cause the cached package to disappear after a few days' time? This has happened on at least 3 of the computers; I'm still waiting for my remaining users to find a "convenient" time to log out, thus completing the process; therefore, I don't know how many computers will eventually be affected by this.

Flushing the "Cache the package" policy history for a computer which had received an error during the "Install the cached package" policy will cause the package to be cached again; once I see that has occurred, I can then flush the policy history on the "Install the cached package" policy, and beg the user to pretty-please log out...

Questions:
Shouldn't this have worked the first time?
Did I do something wrong? If so, what?
What procedure do the rest of you use to roll out updates of applications that are constantly in use on the workstations?

2 REPLIES 2

mainelysteve
Valued Contributor

Do you happen to own an early 80's stainless steel sports car with some slight modifications to the interior and exterior? 

Serious question though. Are you still running OSX 10 Panther and Office 2004 or did auto complete have a field day?

mm2270
Legendary Contributor II

I'm equally confused. Did the Jamf forum somehow belch up an ancient post from its archives as a new post? The beginning of this mentions not wanting to send a lengthy email to the list. "the list" is a throwback to when the forum was nothing more than a mailing list and not an actual web based forum. And "Mac OS X 10.3.9"? Seriously, nobody could be running that anymore unless they traveled in time to present day from 18 years in the past!

It shows posted 17 hours ago, but given the clues here, either something went wrong with the forum software or someone is playing a practical joke on us.