Updated to Server 5.0.15 and it made my JSS link go to an OS X Server site

New Contributor III

I just updated Server 5 to version 5.0.15 and it made my JSS link go to the OS X Server page instead of the JSS login screen. Any ideas on how to get this back?


New Contributor II

I ran into that with a previous update. Restarting the Mac fixed it. Best of luck.

New Contributor III

Thats basically what I had to do. I also had to go in and # out port 8443 in a conf file. I just didn't restart the server after doing that. After restarting the server it came back up fine.


Valued Contributor

Yup - it's a mess, and it takes some interesting Google foo to piece together what is actually going on. With Server 5.0.5 (and possibly 5.0.4) a proxy service is turned on that monitors the following ports when you turn on the Websites service in Server.app:

80, 443, 8008, 8800, 8443, 8843

I've highlighted 8443 there because that port is used by the JSS web interface. Depending on which service launches first, they will "fight" for control of that service port. Most of the time OS X Server will get apache running first before Tomcat is running for your JSS. When ever you go to one of these ports in your web browser, you will get the default OS X web page rather than Casper.

How to fix this (in my experience today):

Turn off the Websites service in Server.app.

Temporarily turn off JSS/Tomcat:

sudo launchctl unload /Library/LaunchDaemons/com.jamfsoftware.tomcat.plist

Backup the following file that configures the proxy service:

sudo cp /Library/Server/Web/Config/Proxy/apache_serviceproxy.conf /Library/Server/Web/Config/Proxy/apache_serviceproxy.conf.backup

Edit the file:

sudo nano /Library/Server/Web/Config/Proxy/apache_serviceproxy.conf

So that it looks like the following in the section that handles port monitoring, and comment out 8443:

listen 80
listen 443
listen 8008
listen 8800
# listen 8443
listen 8843

Save the edits. Then restart JSS/Tomcat:

sudo launchctl load /Library/LaunchDaemons/com.jamfsoftware.tomcat.plist

Then restart the Websites service. Everything should be operational at that point. I only run File Sharing, Websites, and JSS on this server, so I don't think the changes I made will affect anything on the server, but if your OS X Server is running other services besides those three, these changes may break something else, so YMMV.

Hope this helps those that have been scratching their head over this like I have today. In my case, the com.apple.serviceproxy process was continually crashing and relaunching in the OS X Console, which lead me down this path/workaround.


Valued Contributor III

Hey all any of you running AST from GSX? Did this also brick your ability to run MRI?

Gabe Shackney
Princeton Public Schools

Gabe Shackney
Princeton Public Schools

New Contributor III

AST is working fine on my Server running 5.0.15. Still on Yosemite though.

New Contributor II

Never mind. I had dome something stupid with the keystore. Doh! It's working now.


Scary for a moment, following taugust04's fix and a reboot resolved the issue. I'm surprised this wasn't caught in QA :(


New Contributor

This just saved my A$$ @taugust04!!!!!!! Thanks for sharing. I rebooted and the crap hit the fan. THANK YOU AGAIN!