Upgrade from 9.91 -> 9.96 keeps failing?



I'm trying to update our Windows based JSS (currently managing 236 clients) from 9.91 to 9.96 since yesterday but it keeps hanging on different stages in the web interface when Apache is booted after the initial installation is complete. I've tried it 3 times now, as the local administrator, cleanly shutting down Apache first but every time it's either hanging on Initializing Policies... or simply Initializing... with the progress bar still moving for a very long time.

My first thought was that this is a pretty big upgrade which needed some time but does it really take more than 3 hours? I've checked with mysqlcheck if the database has issues but all the tables are fine.

My last try was to install 9.93 to see if the upgrade straight to 9.96 was the issue but that resulted in the same behaviour.

For the record: I've already done multiple upgrades without any trouble so this seems a bit strange.

Does anyone has any clues what could be going on and have some troubleshooting advice? Am I just impatient and do I have to wait a little longer?

Thanks in advance!





Are you using the default 8443 port?

I noticed during upgrading our test JSS from 9.92 > 9.93 (When Tomcat 8 was introduced) that the upgrade failed when the connector was configured to port 443 instead of 8443. After switching back to 8443 for the upgrade it all went through ok.

My JSS is sat on a CentOS box so monitoring /usr/local/jss/logs/JAMFSoftwareServer.log helped me out.


Yes, I am using port 8443. I indeed noticed that tomcat upgrades to v8, could that be an issue somehow?

New Contributor

I had the same when I upgraded to 9.92 and the issue was that somehow the maximum memory pool for tomcat was lowered to only 1GB. So after I changed this the issue was solved for my JSS.

Hope this helps.

Valued Contributor III

I'm seeing the same issue on mine, upgrading from 9.83 to 9.96. It hangs on a different "Initializing" section each time, like "user-initiated enrollment" or "policies."

So far I've tried uninstalling/reinstalling and restoring the database a couple times, but haven't gone farther than that.

Edit: I've tried upping the max memory for Tomcat, and it keeps resetting to 512MB for some reason.


I've checked the Tomcat settings and increased the maximum memory to 2048 as a test (opposed to the default 1gb in my environment) but no luck... CPU usage also goes through the roof after this change (probably because my VM only has 4gb of RAM)


I performed the same update on OSX and MySQL randomly crashed. I chalked it down to the database being corrupted, but after a rebuild I got the same random crashing.
I'm now dead in the water.
I'm downgrading today.

Contributor II

I am doing my upgrade tomorrow night. If I have anything of value to add I will post here, but I will say that my past few upgrades have all been of the hair pulling variety.


Anyone else has any tips? I think that I'm going to submit a support ticket.


I successfully upgraded our production box at the weekend. We run CentOS6 on a VM with 2 CPUS and 4Gb of Memory, Java 1.8.0_91, MySQL 5.6.32 and have a database size of 2.8Gb.

During the upgrade I monitored the JAMFSoftwareServer.log and watched as the tables got altered and new ones got created. I had one failure with the MigrateGSXConnection but as we don't use GSX not really worried about that.

The last table to be created was - Creating Table: wallpaper_auto_management_settings

The upgrade process took about 4 minutes to complete and once I saw Finished JSS Initialisation in the log the web front end had a login prompt.

If it's getting stuck during a table alteration or insertion you could also turn on logging in MySQL and monitor that log too. Hopefully you would be able to find the table or row in a table that is causing the issue.

Good luck :)