" You are attempting to connect to the server " Dialog box since 10.12.4

stiermanc
New Contributor

I've upgraded my test Mac to 10.12.4 and upgraded the JSS to 9.98. I have a script that runs that maps the network drives that a particular computer needs. It hasn't been an issue up until 10.12.4. Now when the drives auto map at login I get a message telling me "You are attempting to connect to the server "servername". Press connect to continue. Pressing connect attaches the network share and all is well, but the box comes up for each individual server being connected to. I also wipe my profiles every restart as this is a lab environment so the messages come up every single time someone logs in. I searched the error message and didn't come up with anything. Is anyone else seeing this message?

d202a2a90ebb46eb854417fd57ca4513

11 REPLIES 11

donmontalvo
Esteemed Contributor II

This is pretty new too...I guess macOS Sierra is trying to keep us safe...

49e959b186384b49b84f7723643b1c1b

--
https://donmontalvo.com

Nix4Life
Valued Contributor

@donmontalvo is that you testing the tethered caching in 10.12.4? if so what are your thoughts..Oh and no Deadpool pic?

donmontalvo
Esteemed Contributor II

Ahh that makes sense, saw the feature but didn't get a chance to read up on it.

https://www.youtube.com/watch?v=ptKgRecPi1I

--
https://donmontalvo.com

bentoms
Honored Contributor III
Honored Contributor III

Hi folks, Apple have a KB on this: here

Seems the key is not settable with a profile, but script should work.

stiermanc
New Contributor

So it looks like that should only need to be done once per computer and it should stick indefinitely....

CasperSally
Valued Contributor II

@bentoms saves me again - thanks! I also put a ticket in with apple asking for profile setting for this. # 100184809914 if anyone wants ti piggy back

bentoms
Honored Contributor III
Honored Contributor III

@CasperSally NP, it would be really useful to know what Apple classifies as an "Unknown" server.. we've seen the same with folks & Kerberos tickets.

ChicagoGuy1984
New Contributor III

Simple one liner seems to take care of the pop-up for All users on the machine, fresh users as well as existing. works well in our labs that we just updated to 10.12.6

sudo defaults write /Library/Preferences/com.apple.NetworkAuthorization AllowUnknownServers -bool YES

mgshepherd
Contributor

I tried to make a config profile based on the com.apple.NetworkAuthroization.plist file but it seems to not work. Once I created the plist by using the suggested terminal string mentioned by @ChicagoGuy1984 the server connection message is suppressed. Has anyone been able to make a config profile and it work?

mlavine
Contributor

For anyone who wants, Apple has the article about this here: If you‘re asked to click Connect before reconnecting to a server

dpratl
Contributor II

Hi @ChicagoGuy1984,

Perfect, that worked 🙂

Thank you
BR
Daniel