Turn off Chrome's built in Print Preview to use OS X native print preview

Oops_wasn_t_me
New Contributor II

Good Morning,

With the latest versions of Google Chrome (Version 45.0.2454.85 (64-bit)), when printing, by default Chrome uses its own built-in Print Preview functionality. i.e. it doesn't use the System Print dialog display.

I want to disable Chromes built-in Print Preview functionality completely so whenever an end-user prints, it uses the OS X native system print dialogue but I can not seem to turn off Chromes built-in Print Preview functionality. I have tired using the defaults write option:

defaults write com.google.Chrome DisablePrintPreview -boolean true

and also remapping the Command-P functionality using keyboard mapping (http://ryan.mcgeary.org/2012/09/13/disable-chrome-print-dialog-use-osx-instead/) but neither approach works. Oddly enough, when the defaults write option is actioned, the Chrome .plist (~/Library/Preferences/com.google.Chrome.plist) reflects the change (DisablePrintPreview, Boolean, Yes) but still operates using Chromes' own Print Preview functionality. Is there a cache setting somewhere which overrides the .plist ?

Ideally, I would like to disable Chromes' Builtin Print Preview Functionality completely so that Chrome has to present OS X native system print preview. Hence, when an end user chooses to print via the File -> Print or via clicking on print button on a web page, Chrome will present the standard OS X system print dialog.

Has anyone had any success with this problem ? Your advice is very much appreciated.
Have a great day.
Thank you.

1 ACCEPTED SOLUTION

lwindram
Contributor

I do it using the same process outlined by @jacob_salmela.

I would add one caveat: Chrome doesn't appear to like having multiple config profiles. We use LanSchool and the installer adds a chrome config profile. With both enabled, neither worked. I now prevent the LanSchool config from installing and all my config profile settings are correctly applied.

And I'll second that the defaults write command in your original post has no apparent functionality re: printing.

View solution in original post

11 REPLIES 11

jacob_salmela
Contributor II

I use a config profile for this:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>DisablePrintPreview</key>
    <true/>
    <key>PMPrintingExpandedStateForPrint2</key>
    <true/>
</dict>
</plist>

boberito
Valued Contributor

Did the same as jacob.

Oops_wasn_t_me
New Contributor II

Good Morning,

Thank you for your responses. I will investigate further and provide an update once I have had a chance to test against our environment.

Have a great day.
Thank you.

lwindram
Contributor

I do it using the same process outlined by @jacob_salmela.

I would add one caveat: Chrome doesn't appear to like having multiple config profiles. We use LanSchool and the installer adds a chrome config profile. With both enabled, neither worked. I now prevent the LanSchool config from installing and all my config profile settings are correctly applied.

And I'll second that the defaults write command in your original post has no apparent functionality re: printing.

bpavlov
Honored Contributor

@jacob_salmela I thought that was deprecated in more recent versions of Chrome.
https://www.chromium.org/administrators/policy-list-3#DisablePrintPreview

Are you saying that still works for you? I tried testing it a few months ago, but not via a profile and it didn't work.

jacob_salmela
Contributor II

Yes, it seems to still be working despite that. Just tested on a machine running 45.0.2454.85.

Oops_wasn_t_me
New Contributor II

Hey,

@ jacob_salmela and @lwindram, thank you for your suggestions. It turned out to be a profile conflict with Chrome - just as @lwindram suggested.

Appreciate everyone's feedback.
Thank you.

dmarcnw
New Contributor III

You could also run a script to disable it.

This is what we use to turn it off for users:

#!/bin/sh
#
# This will override Chrome's setting for Google Print Dialog. This allows Apple Print Dialog to show up.
# Change -boolean true to -boolean false to enable Google Print Dialog again.
#
defaults write com.google.Chrome DisablePrintPreview -boolean true

EliasG
Contributor

@jacob_salmela so whats the correct script to make this work in google?

jacob_salmela
Contributor II

@EliasG I'm not sure..It's been a few years since I've been in the Mac world, and I can't recall this post.

kanea
New Contributor

@eliasG I have used the following defaults write option successfully:

defaults write com.google.Chrome DisablePrintPreview -bool true