Disable stealthmode using terminal

tngo3
New Contributor

All,

I'm trying to run the following command but it's not having the expected effect. Am I missing something?

sudo /usr/libexec/ApplicationFirewall/socketfilterfw --setstealthmode off

Thanks!

2 REPLIES 2

roiegat
Contributor II

Do you have a configuration profile in place that might be keeping it on?

boberito
Valued Contributor

@tngo3 What are you expecting? It should just be turning stealth mode off so that the machine would respond to pings basically. You can read the preference to see if it's changing the value

defaults read /Library/Preferences/com.apple.alf stealthenabled

@roiegat This is one of the fun places where the binary trumps a config profile. The firewall and gatekeeper are the 2 frustrating places where this happens.