Jamf Connect Chrome extension not redirecting to Jamf Connect Sync app

glaske
New Contributor III

Hey all - odd thing happening in our environment and haven’t seen anything in the search function regarding this. We have had Jamf Connect Sync deployed since it was NoMAD Pro and never had any issues with it. Just about two weeks ago, any new computer that was setup is having an issue where the redirect to Jamf Connect Sync via Google Chrome just hangs and never does anything. I was told this is a PI and it might not be resolved, but I assume there are tons of others using Google Chrome. We haven’t changed any preferences or versions (running the latest for both Login and Sync) and any computer that was setup before the issue started is using the same configs and versions…really just blows my mind that this is happening and have no idea how to solve it, especially since all the machines before this happened are still working with no issue running the same config. Chrome is our main browser and basically our JCS for all newly setup computers is worthless. Going to JCS and signing in logs us into Chrome and takes us to the Okta dashboard, but once Chrome is closed or the token expires, the redirect is shown to the user again with JCS never opening and taking over the sign in. Any ideas or anyone else running into this? Funny enough, Safari is working just fine.

Thanks all πŸ™‚
8f3170680614475b903116768017da8e

5 REPLIES 5

gregreznik
New Contributor III

+1 to this, same issue here.

glaske
New Contributor III

I did some troubleshooting of the Native Messaging in Chrome and have been able to see what I think the issue is and how to resolve it.

After enabling Developer mode and collecting errors for the extension, I immediately started seeing the following error:

Unchecked runtime.lastError: Specified native messaging host not found

I then navigated to "/Library/Google/Chrome/NativeMessagingHosts/" and found on the test machine only one file. This file was the "jamf connect-chrome" unix executable.

When looking at a machine that works with no issues, I am seeing both "jamfconnect-chrome" and it’s corresponding json, and a "NoMAD-Chrome" executable and it's corresponding json.

If I move the "NoMAD-Chrome" executable and it's corresponding json file to the " NativeMessagingHosts" folder on a machine that is having issues, the redirect will start working again with no issue. It appears the error comes from the fact that the extension is actually looking for the "NoMAD-Chrome" native messenger in Chrome and not the "jamf connect-chrome" messenger. This is confirmed in the error logs.

With that, it appears that any machine that previously had NoMAD Pro on it works with no issue, but any new machine that only has the Jamf Connect Suite installed receives this native messaging error as the "NoMAD-Chrome" messenger is not there.

I forwarded this info to support as well and it's been escalated to Tier 4. Will post here if I get any info back.

gregreznik
New Contributor III

@glaske I really hope Jamf escalates this quickly and gets a fix out, since you've pretty much done the work for them in identifying the issue... =D

Nice work!

selleos
New Contributor II

Woah, I reported this issue over a month ago and received a response that it's being addressed and a fix will be deployed later. Great work @glaske

glaske
New Contributor III

Thanks all for the replies @dselleos and @bayareag - as of now, I have been told that no point release fix will be released for this issue and that Jamf Connect 2.0 will have to be deployed to resolve it.

In the meantime, if you wish to resolve this issue you can take the "NOMAD-chrome" executable and it's corresponding json "menu.nomad.nomadpro.json" and deploy it to the machine that is having issues. You should be able to find these files on a machine that previously had NoMAD Pro installed. These two files can be found in "/Library/Google/Chrome/NativeMessagingHosts/" and should also be deployed to the same folder. This have resolved the issue on all machines in question for me.

Hope this helps!