Jamf Connect Login - sync behaviour explanation

44r3n
New Contributor II

Good Morning,

we are working with Azure 365 (no Kerberos) and Jamf Connect Login configuration. I've installed 2.6.0 right now and I am happy that the "verify" step is not necessary anymore. Only one Authentification! Awesome.

Can someone explain me if this behaviour is correct:

  • User authenticates with M365
  • Local user is created with M365 password sync
  • Jamf Connect Icon is showing on top of menu bar

If an admin changes the M365 password - does the user should be notified that the local password is out of sync with the M365 after 15 minutes?

Right now I've changed the password but the logged in user did not get any information.

Thank you in advance.

Best Regards

 

4 REPLIES 4

44r3n
New Contributor II

Good Morning,

another strange thing is - if I reboot I get the local account login and I can login with the old password even the M365 password is changed or different.

As far as to my knowledge I thought that the passwords local and M365 are always checked if they are in sync?

From the manual I understand this:

jamf-connect-info.png

But our problem is the user is not receiving any information if the passwords are out of sync!

Did I miss to configure something?

Thank you very much.

Best Regards

44r3n

mjhersh
New Contributor III

When you reboot, are you seeing the macOS login screen, or the FileVault authentication screen? They look very similar but they are not the same thing, and the FileVault authentication will automatically pass through to the desktop, bypassing the Jamf Connect Login screen. No password syncing will happen during this process, so you'll need to rely on the menu bar applet to nag the user.

Also, when you made your config in Jamf Connect Configuration, did you check the "Automatic Sign-in" box under the Connect tab? If you don't check that, then you'll need to manually select Connect from the menu bar applet after logging in.

44r3n
New Contributor II

@mjhershthank you for your reply.

Also, when you made your config in Jamf Connect Configuration, did you check the "Automatic Sign-in" box under the Connect tab? If you don't check that, then you'll need to manually select Connect from the menu bar applet after logging in.

Where can I find the checkbox for "Automatic Sign-in" box. Thank you, but I think it's connected because the login credentials are filled and grayed out, when clicking on connect.

mjhersh
New Contributor III

It's in the Connect tab of the Jamf Connect Configuration app. See attached screenshot. Though if you're manually selecting Connect from the menu and it still isn't prompting you to synchronize passwords, there's probably a different problem.

Screen Shot 2021-11-03 at 9.45.19 AM.png