M3 Mac enrollment issue?

New Contributor II

We just received our first M3 laptops. Wanted to see if these could be downgraded to Ventura, but it appears Apple has locked these to Sonoma. Not ideal, but that's not the real issue. I've only tried 1 so far, but after the auto-enrollment, the screen goes black with no cursor and doesn't respond. Reboot didn't help. I'm able to go to recovery, and am trying reinstall of Sonoma now. Just wanted to see if anyone has enrolled M3 Macs with Jamf yet. For context, this is a MBP 14 and we are on Jamf Cloud. If issue persists after reinstall of OS, I'll try another one of the M3s. Thanks in advance.


New Contributor II

Have you updated Jamf Connect? Sounds like the issue others were experiencing in the comments here https://community.jamf.com/t5/jamf-nation/macos-sonoma-with-jamf-connect/m-p/300261

New Contributor III

As lardvoldemort stated, check the version of Jamf Connect you're installing. You'll need Jamf Connect v2.28 or higher  to stop the issues with Sonoma. 

Also, Jamf just sent out an email saying that if you have macOS 14.2 installed, you need to update Jamf Connect to v2.29 or you'll encounter a black screen.

What service emailed this to you? I have not received anything from JAMF in regards to that.

This announcement came directly from Jamf Product Notification at 3:30pm (CST). I assume it's going to be sent out to all customers. 

I never did test Jamf Connect 2.27, our environment was running 2.26 and it was causing a grey screen on all macOS 14 machines. JC v2.28 resolved that issue for us. 

Thanks, I'll check this out. I just saw that email, btw.

New Contributor

Yeah, I have our environment on 14 or 14.1 and Jamf Connect 2.27 works for us. I work with another district that went to 2.28 and the black screen issue persisted. So just something to consider.

New Contributor II

Just a quick update. This machine has 14.1.1 installed, according to Jamf Pro. I have set up 2 config profiles for license and settings as well as a policy for Jamf connect and launch agent 2.29, scoped to only this machine. The machine is on network and at black screen. Am I correct in thinking once this thing checks in again, the policy will install that version and reboot the machine, and all should be good? This is what I understood from Jamf email on issue.

That process is exactly what I had to do to fix the machines that were giving me the grey screen (macOS 14.0 and JamfConnect v2.24). I had the config profiles and policy scoped to this machine while on network. Once the policy for Jamf Connect v2.28 ran and the config profiles were applied, I restarted the machine and it was good to go. 

New Contributor II

Yes, this worked for me. Thanks for everyone's quick responses.