Some devices are falling into both of my Smart Groups to split up Intel and Apple Silicon devices

New Contributor III

In our Jamf Pro instance, I have two smart computer groups, one for Intel devices and another for Apple Silicon. The criteria is pretty straight forward in each:

  • Apple Silicon group == "Apple Silicon is 'yes'" [OR] "Architecture Type is 'arm64'"
  • Intel group == "Apple Silicon is 'no'" [OR] "Architecture Type is 'x86_64'"

However, I have 30 devices (of ~800) that are failing into both groups for some reason.  These devices were fresh enrollments as of earlier this year or late last year, and they are all properly checking in and performing inventory updates. The criteria is correct on each device too.

I tried making two new test smart groups with different criteria, and the exact same thing happens!

  • Apple Silicon group == "Apple Silicon is 'yes'" [OR] "Processor Type like 'Apple'"
  • Intel group == "Apple Silicon is 'no'" [OR] "Processor Type like 'Intel'"

Anyone else seeing this? Not sure what to make of this, because as far as I can tell I'm not necessarily building the criteria incorrectly.

EDIT: Well, nevermind... Solved. But wanted to post my answer for anyone else seeing this.  Or if anyone can explain why it behaves this way. Turns out the Apple Silicon criteria was causing the fuss.  If I only include Architecture or Processor type, everything is correct. So now my config is:

  • Apple Silicon group == "Processor Type like 'Apple'"
  • Intel group == "Processor Type like 'Intel'"

Looking closer I think these devices were also all not macOS 12 yet, which doesn't' collect that Apple Silicon attribute... which is why I included it with an [OR] criteria. Guess it's a quirk (or bug?) with how smart groups process under that circumstance.



Honored Contributor

Yep, found that one the same's odd, but you found the answer.  And thanks for posting it up.  Many don't 😉


Yes, I had to do it by processor type as well!  I can't wait til we get everyone off Intel then I don't have to worry about that LOL

New Contributor III

Wacky, the same bug is definitely still there and your workaround still works.