10.10.3 netboot issues, going crazy


Hi guys, I need some new ideas because I'm sure I'm doing something wrong but can't figure out what. I haven't used netboot for a couple years because with the few Macs that we have there is no real need for it. But there might be more Macs coming soon, so it was time to get back into this project.

Long story short, here is what I did:
- Set up new test environment with a MacMini 6,2 as server, clean install of 10.10.3, clean install of Server 4.1, all updates applied
- Using the 10.10.3 SIU I created a NetInstall image from the 10.10.3 installer app (fresh download from the app store)
- Added the image to my new NetBoot server, made it the default, all green
- Took a MacBook Air 6,2, set the new NetInstall image as Startup disk and rebooted
- The MBA blinks the globe a few times (maybe 10) and then boots from the internal disk, ignoring my NetInstall image
- Rebooted with Option key, select netinstall image, screen freezes for a while, then boot from internal disk
- Took a MBA 5,2, same thing
- Tried my MBA 7,2, it doesn't even blink, just goes black for a while and then boots from the internal disk
- Recreated the NetInstall image, same result.
- system.log shows the MBA7,2 trying to boot but that's it

Apr 16 10:00:40 usitiljss01.local bootpd[42196]: BSDP INFORM [en0] 1,40:6c:8f:43:53:cf NetBoot002 arch=i386 sysid=MacBookAir7,2
Apr 16 10:00:40 usitiljss01.local bootpd[42196]: NetBoot: [1,40:6c:8f:43:53:cf] BSDP ACK[LIST] sent pktsize 326
Apr 16 10:00:41 usitiljss01.local bootpd[42196]: BSDP INFORM [en0] 1,40:6c:8f:43:53:cf NetBoot002 arch=i386 sysid=MacBookAir7,2
Apr 16 10:00:41 usitiljss01.local bootpd[42196]: NetBoot: [1,40:6c:8f:43:53:cf] BSDP ACK[LIST] sent pktsize 326
Apr 16 10:00:42 usitiljss01.local bootpd[42196]: BSDP INFORM [en0] 1,40:6c:8f:43:53:cf NetBoot002 arch=i386 sysid=MacBookAir7,2
Apr 16 10:00:42 usitiljss01.local bootpd[42196]: NetBoot: [1,40:6c:8f:43:53:cf] BSDP ACK[SELECT] sent pktsize 399
Apr 16 10:00:58 usitiljss01.local bootpd[42196]: BSDP INFORM [en0] 1,40:6c:8f:43:53:cf NetBoot002 arch=i386 sysid=MacBookAir7,2
Apr 16 10:00:58 usitiljss01.local bootpd[42196]: NetBoot: [1,40:6c:8f:43:53:cf] BSDP ACK[SELECT] sent pktsize 399
Apr 16 10:01:16 usitiljss01.local bootpd[42196]: BSDP INFORM [en0] 1,40:6c:8f:43:53:cf NetBoot002 arch=i386 sysid=MacBookAir7,2
Apr 16 10:01:16 usitiljss01.local bootpd[42196]: NetBoot: [1,40:6c:8f:43:53:cf] BSDP ACK[SELECT] sent pktsize 399
Apr 16 10:01:32 usitiljss01.local bootpd[42196]: BSDP INFORM [en0] 1,40:6c:8f:43:53:cf NetBoot002 arch=i386 sysid=MacBookAir7,2
Apr 16 10:01:32 usitiljss01.local bootpd[42196]: NetBoot: [1,40:6c:8f:43:53:cf] BSDP ACK[SELECT] sent pktsize 399

- Created a new NetInstall image from my 10.10.0 installer app
- Tried the MBA 5,2 and MBA 6,2 and they booted right away from that image
- The MBA 7,2 will obviously not boot because it's too new but I got the circle thingy telling me that it found the image and tried to boot from it
- I don't have 10.10.1 or 10.10.2 installer apps, so I can't test those
- I tried to create a 10.10.0 + 10.10.3 update NetRestore created with AutoDMG which works with the MBA 5,2/6,2 but not with the MBA 7,2
- I tried a MacBook Pro 11,1 as server, with 10.10.0 and Server 4.0, same result
- Created 10.9.5 and 10.8.5 images, they work fine on the machines that support those OSes
- I tired NetBoot, NetInstall and NetRestore, same result
- I tried the NetSUS 3.0.1 appliance, same result
- I tried adding the 10.10.3 netboot.dmg to the 10.10.0 NBI, same result
- Tried AutoCasperNBI, same result
- Tried changing http to nfs, same result
- Changed the router from a Cisco VPN router to an Apple Airport Extreme, same thing
- All machines boot fine from a USB drive that I restored the various images to

So, since Wednesday last week I'm trying to find anything on the Internet that would be similar to my issue but came up empty handed.

Does anybody here have any idea what I might be doing wrong? Anybody here with a similar setup succeeding?



New Contributor II

I'm seeing the same issue and it is driving me crazy. I thought it was an issue with the update to SIU but not i'm not sure. It is definitely an issue with 10.10.3/Server 4.1. I was able to build and boot to images with the new MBA13/MBP13 no problem before the release. When I upgraded my dev server to try and unfork the images now they don't boot at all. I get the black screen and it goes straight to internal disk.

Contributor II

Please post the following info please.

Screen shots of your mac mini about this mac where it shows OS version with build #

and double click your netboot image where it shows details and diskless.


Valued Contributor II

Use AutoDMG to build your never-booted up-to-date base OS from the 10.10.3 installer.
Use AutoCasperNBI to take that base OS image and build a NetBoot image.

This workflow works. I can't speak for SIU as I avoid it like the plague due to its hit-or-miss nature/extreme bugginess in the past.


This is the AutoCasperNBI that I have created from a AutoDMG image that was created today based on 10.10.3 installer app that was downloaded today


This is the NetRestore that I created today with SIU from the same 10.10.3 installer app


Contributor II

In the about this mac click on where is says 10.10.3 it should show a build # something like (15D141)



yep, that's what it says

Honored Contributor II
Honored Contributor II

We've got Netboot in use a loads of our clients sites. None on 10.10.3 yet I'm afraid.

It sounds like you've tried quite a lot already. From your list it sounds like:

  • The general Netboot "plumbing" is working as an earlier 10.10.0 image is ok
  • The issue seems to be specific to 10.10.3 netboot images

The only things that come to mind at the moment are:

  • The server versions are at fault and (for some reason) are not able to host a 10.10.3 NBI. This would certainly be the case with something like a 10.7 server hosting a 10.10 image but could be a root cause here.
  • There is a new issue with the NBI creation tools and 10.10.3, similar to the kernel cache size problems that were overcome before.

The other troubleshooting step I would suggest is to take log samples from the server for a successful 10.10.0 netboot and a failing 10.10.3 netboot so it is clearer where it is falling down.

Sorry its not a definitive answer, just thought I'd throw in the thoughts in my head on the issue! Hope its of some help.

Valued Contributor II

Try changing from http to NFS. I've had some sites where one worked when the other doesn't, and vice versa. No rhyme or reason why.

It is also useful to try to boot in Verbose mode (hold Command and V down) on one of the clients you are trying to NetBoot from. You'll get much more useful info from that than you will from the server's log.

Contributor II

I am running 10.10.3 with Server 4.1 on a Mac Pro. With a 10.10.3 image for my MacBookAir 7,2

I would try building your image from one of your macs versions you are tying to image not from the server. Once that NBI is created copy and move it to your servers Library/Netboot/NetBootSP0


I just tried the following without any effect:

  • Updated the Mac Mini server to 10.10.3 14D136 (the update released today).
  • Booted the MBA 7,2 command+R and installed its OS (same 10.10.3 14D131 as before) to an external USB drive, rebooted from the internal drive, used SIU to create a NetRestore from the external Usb drive.
  • Tried to verbose boot the MBA 6,2 but it seems that verbose mode does not work for the network boot phase, it shows something only after it started booting from a drive.
  • I tried NFS before without any difference but tried it again.
  • Tried to run Server 4.0 on 10.10.3 but that doesn't work.
  • Tried Server 4.0 on 10.10.0 updated to 10.10.2 but that didn't make a difference with the 10.10.3 images.
  • Re-downlaoded the 10.10.3 installer app which is now 14D136, created a new NetBoot with SIU

None of the above allowed me to netboot into a 10.10.3 image.

I'm glad that I'm not the only one but I don't understand why it works for some but doesn't work for others. I used my MM5,2, MBP11,1, MBA 6,2 and MBA 5,2 as well as NetSUS 301 as server, nothing seems to make a difference.


Now it gets interesting:
- Installed Server 4.1 on my MacPro 6,1, added the 10.10.3 14D136 NetInstall image that I just created with SIU on the Mac Mini and the MBA 7,2 boots just fine
- Neither the MBA 5,2/6,2 nor the MBP11,1 will boot from that image though, they all boot from the internal drive after a little delay
-the latter three boot fine with the 10.10.0 image that I created earlier

To be continued...


We had this issue for many years (with the release of 10.7). We pretty much abandoned NetBoot and went straight thin-imaging. I worked with our network tech on it and now we can boot 10.10.3 from the NetSUS server (but not the Mac Mini with OS X Server 10.9). Probably not the same as you as you can boot 10.10 images. FWIW, I built my base DMG with the latest Yosemite installer using AutoDMG and my NetBoot folder using AutoCasperNBI. I just NetBoot imaged a new 13 MBP with the ForceTouch trackpad today with no issues.


@johnnasset My apologies for asking a stupid question (I'm mainly a Windows guy) but is there another option to boot a Mac from the network without using Apple Server or one of the open source Netboot options? If I'm not mistaken, Casper, DeployCenter and similar all require a netboot server, correct? Does thin-imaging mean you boot from an external drive (USB, Thunderbolt) or in Target Mode instead of the network?


No problem. I have only used Apples NetBoot and the NetSUS available from JAMF. I know there are some other options like Deploy Studio but I don't have any experience with them. I prefer the NetSUS appliance as it installs easily in vSphere and does everything we need.

For my thin-imaging workflow, typically I would start the new mac and go through the initial setup, create my admin account then add the machine to Casper via a QuickAdd.pkg deployed with Apple Remote Desktop. Once enrolled in the JSS, we have a policy with a custom trigger that goes through and installs additional apps, binds to AD, etc. Works fine for a few at a time but could get tedious with a large deployment. With my NetBoot thin-image, I have a configuration with our desired apps/scripts/bindings/etc and just boot into Casper Imaging and deploy that configuration (making sure not to wipe the HD!!) Definitely more hands off with this approach. You could setup a pre-stage in the JSS for a large deployment and just NetBoot and walk away. That said, it would be helpful if your Netboot was working.

New Contributor

With Netboot/SUS can you use SMB to deploy the image and packages? I have an iOS netboot server setup and unfortunately the only way to deliver the image and packages is via AFP. I wanted to put all my packages/images on a windows share put can't because of this limitation.

Valued Contributor


I don't know why anyone persists with NetSUS or NetBoot server on OS X

BSDPy is the one netboot server to rule them all, solid as a rock. Dockerised, so deployment can't be easier


@calumhunter BSDPy seems to be a nice tool but it also seems to be hard core *nix style. For a Windows guy like me it's almost like reading Chinese. My fault I know and it will probably change. But for now a commercial solution where I can call someone in case it doesn't work fits my environment better. Maybe if there would be a BSDPy for OS X and/or a BSDPy for Dummies guide it would become more interesting.

Valued Contributor II

@calumhunter I think the big issue with BSDPy and similar tools is the cost-of-entry. If you're an old-school Linux hack that's fine, but there is a huge difference between OS X Server's On/Off toggle and BSDPy when it comes to UI and complexity. I respect the work Pepijn and others have put in, but just being honest. The open-source tools (AutoPKG munki et. al.) are great, but much better/more readily adopted when someone puts a GUI (AutoPkgr, MunkiAdmin) on them...

Plus many of the problems people have with NetBoot in general are network-related (i.e. NBAS/ip=helper or NAC'd connections) that the choice of platform is irrelevant.

New Contributor

i can confirm im getting the exact same problem, mavericks server 10.9.5, created the netboot on a new 13" early 2015 macbook pro retina, using autodmg and autocaspernbi

New Contributor

scrap that, Used Capser Net Install Creator and its netbooting from 10.10.3 now

and just found this post as well



So, long story short, I got it working. I feel almost embarrassed how simple it was at the end although the solution doesn't explain why I ran into the issue in the first place and how to avoid it without replacing network hardware. My apologies for the long reply but I hope this will help some others to track down their netboot issues when they find this post.

I have two networks with a little server room on one side and my office on the other side that grew over the years as more devices got added. Initially I started with a few Cisco SG100D-08 unmanaged switches which were later replaced by Cisco SG102-24 unmanaged switches. In the server room I started with a Cisco Catalyst 3560G which was later replaced by a Cisco Catalyst 4948. The work network connects to a Cisco 2800 VPN router, the home network connects to a current generation Airport Extreme.

Remind you, Netbook/Netinstall/Netrestore was working with 10.10.0 or older on any hardware that is supported. Only 10.10.3 was not allowing any of my machines to boot. I was able to select the NBI as Startup Disk or select it with the Option key pressed but I got nowhere after that.

Today I decided to start over with the smallest possible network. I connected a Linksys E3000 to my home network as Internet uplink (I know, double NATing is bad), a Macbook Pro 11,1 as server and a Macbook Air 5,2/6,2/7,2 as clients. And guess what, all clients booted just fine from any of the NBIs that I had created earlier. I tried other Macintosh models and none showed any issues anymore.

After that eye opening experience I decided to get my old SG100D switches out of the basement and daisy chain them together just as in the old days, removing all the Catalyst and the SG102-24 from both networks. And everything kept working fine.

Our network guys configured the 3560G and 4948 and I have no idea what they did with them (they will need to figure out what is wrong since we have those switches in all of our offices and need to get them working eventually). But I would have thought that the unmanaged SG102-24 (that has no configuration options at all) would behave just like the SG100D-08. But it wasn't so. I guess it's up to Apple and Cisco to figure out what is wrong with such a setup, more Apple maybe since NBIs of older OS versions work fine.

I'm just happy that I can finally focus on Casper, JSS and Macintosh deployment.

Thanks for all the replies earlier,

Release Candidate Programs Tester

@shoegazer what server were you betbooting from?

@calumhunter as guessed on Twitter & now tested, BSDPy currently doesn't work with "normal" NetBoot Images, only NetInstall images or NetBoot Images that have the rc.netboot edited for RAM disk creation.

Valued Contributor

NetBoot images do work with BSDPy... you just can't unmount the internal HD as its used for shadow storage.
Thats what the rc.netboot script fixes up... creates a ram disk for shadow storage and allows the internal hard disk to be unmounted and therefore imaged.

But for sure there is no problem using a NetBoot image with BSDPy

Release Candidate Programs Tester

@calumhunter that's why I said "normal" NBI's don't work.

The rc.netboot IS NOT needed for OSX Server or NetSUS to image macs or even to boot from an NBI that they are hosting, BSDPy does.

But, gimme time. I'm going to try & get BSDPy working with normal NBI's.

Valued Contributor

and a bit of shameless self promotion for those that say bsdpy is too hard.
Heres a step by step guide for you.



This is a great resource to understand & troubleshoot the fundamentals of OS X Netboot tech.


The more you understand about how the Mac on your desk gets from no local OS X available to a magic state of "running" off the network, the better chance you will have of troubleshooting it when it goes wrong. ie. What is happening during various grey screens, world icons and spinners.

Taught me a lot, enough to cobble together a working Netboot server on the back of a consume WD MyBook live NAS a few years a go.