Advice on common issues when setting up JIM ?

VitorCostaUK
New Contributor III

We’ve taken on Jamf Cloud hosted and are having a few issues setting up the on prem LDAP Sync AKA “ JIM “ .

Both Azure LDAPS Sync and JIM (Jamf Infrastructure Manager) don’t seem to work and I was just looking to see if anyone had the same deployment issue ?

Were currently focusing on getting the On Prem Sync (JIM) configured as the Azure route may have some issues in regards to configuration and ongoing licencing.

No matter what I try our cloud instance does not see our on prem server 2016 JIM in infrastructure managers

Followed all the guides and still stuck

1 ACCEPTED SOLUTION

tdclark
Contributor

This walkthrough was what finally got my 2 JIM's working

https://hcsonline.com/images/PDFs/Jamf_Infrstructure_Manager.pdf

View solution in original post

7 REPLIES 7

prl
Contributor

https://travellingtechguy.eu/integrate-azure-ldap-in-jamf-pro/ Have you tried this guide? No JIM involved at all.

VitorCostaUK
New Contributor III

@prl Yes followed it to the letter set up a free trial instance as our educational Azure didn't support Domain Active directory services, but when i get through to authenticating on Jamf Pro , i get the error that the user cannot be found to authenticate the domain , and thus is where i lie stuck ... raised this with Jamf support and hopefully will get JIM working.

prl
Contributor

Hey @VitorCostaUK I think you may want to edit your search base to make this workflow function: https://travellingtechguy.eu/integrate-azure-ldap-in-jamf-pro/. see here for information on editing your search base: https://travellingtechguy.eu/default-ldap-mapping-for-active-directory-in-jamf/

After editing your search base use the Test button in LDAP settings to see if it returns a user.

Again the above does not require JIM whatsoever, JIM is for linking your on-premise AD server to Jamfcloud. If you have Azure and can afford it, having that cloud to cloud set up is more fun than setting up an on-premise LDAP Proxy on JIM.

tdclark
Contributor

This walkthrough was what finally got my 2 JIM's working

https://hcsonline.com/images/PDFs/Jamf_Infrstructure_Manager.pdf

View solution in original post

VitorCostaUK
New Contributor III

@prl & @tdclark thanks for the pointers , ill try this today ! THANKS !

GiveEmHelms
New Contributor III

@tdclark Do you have an updated version of that PDF? I keep getting a 404 when I go to that link.

Thanks!

sdagley
Honored Contributor II

@GiveEmHelms I was looking for JIM info recently myself, and found "A Guide to Install Jamf Infrastructure Manager on a Windows 2016 Server" on the HCS site. I'm not sure if it's the same document @tdclark references, but it might help.