After upgrading to 10.17.1: Command requires DEP enrollment: UserList <MDMClientError:74>

mhegge
Contributor II

I am working with JAMF Support on a PI that came up after upgrading to 10.17.1

MacOS devices enrolled in DEP showing that they are not:
Enrolled via Automated Device Enrollment: No

And they are showing (sometimes) failed management commands:
UserList Command requires DEP enrollment: UserList <MDMClientError:74>

(PI-006472: UserList mdm command continues to be issued (and fails) when required preconditions are no longer met)

I have a number of devices that are not responding to the workaround and wanted to reach out to the community to see how people have been dealing with it.

Workaround:

1) Remove MDM profile on macOS device
2) sudo profiles renew -type enrollment
3) Select detail on dialog box IF it appears 4) sudo JAMF mdm sometimes needs to be run on computers that do not get the dialog box.

Issue is that this method does not always work.
fe85f0ba603147b9a5a3e2b3eeae50c5

35d044571fa449e7b03e832991a1a44c

2d4b25f934234c03a33e1b6337f81dcc

f93fd88288b14fde83e662135d83c7f2

3 REPLIES 3

mhegge
Contributor II

I am working with Mojave and High Sierra iMacs. I am also seeing something in DEP that states the computers are not assigned to a prestage, when they are. This might be the missing link to issues but JAMF has not given me any feedback on it as of yet.

vorera
New Contributor

Please confirm if this workarount works or not. I have this problem also in my mac device, also the connection of Self Service is not working. Perhaps both issues are connected with same issue

arnokenis
New Contributor III

Was there ever a solution for this problem, I have the issue too here on 60 of my devices.