Airport Off in Configuration Profile

macboy
Contributor

I have looked at this a few times now and not gotten a clear answer. I need to have all the desktop systems in my site turning off airport so that we remove excess chatter on the network. I Have this currently working through Managed Prefs but would like to switch it to Configuration Profiles. I downloaded com.apple.MCXAirPort.manifest from Jamf Nation but not sure where to go from there. Ideas and directions on how to do this? I know I don't remember how to convert plsit to upload into custom either. Been a while since I have looked into this and any help with how to go about this would be appreciated. I don't really want to create a script would rather it be a profile I can force to the machine.

13 REPLIES 13

millersc
Valued Contributor

These two settings will give you what your looking for. Tested on 10.9.3 pushed at the computer level.

com.apple.MCXAirPort.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict> <key>DisableAirPort</key> <true/>
</dict>
</plist>

com.apple.mcxMenuExtras.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict> <key>AirPort.menu</key> <false/>
</dict>
</plist>

macboy
Contributor

So how do I implement this in Configuration Profile millersc? Where do i find the plist and where are directions on how to upload that. I used to have the link for that process but can't seem to find it.

gregneagle
Valued Contributor

FWIW:
https://github.com/gregneagle/profiles/blob/master/mcxairport.mobileconfig

adamcodega
Valued Contributor

If you have a .mobileconfig file like gregneagle posted you can upload it to the JSS from the Configuration Profiles screen.

millersc
Valued Contributor

@macboy
You can created each .plist file with the contents I posted. Then upload each .plist under the Custom Settings.

If you need more functionality you can pull the tags from Greg's config file. I'll see about getting my github setup.

macboy
Contributor

Thanks. I think I got it and will test test test...

macboy
Contributor

@millersc
I got the first plist to work, however, the hide menu plist does not seem to hide the airport menu. I have tried it on both 10.10.2 and 10.9.5. Have you tested it on 10.9.5?

millersc
Valued Contributor

Yep, I have a few 10.9.5 test units. I have seen where it takes a second reboot or second login. Are you hiding anything else, to make sure it's happening at all?

macboy
Contributor

Nope that is the only thing I am hiding. Not a big deal but have another area that might be interested in actually hiding the Airport menu for lab machines.

millersc
Valued Contributor

email me. I'll zip up my files for you to try. You can even just look at them to compare. (steveDOTmillerATuticak12DOTorg)

lsilver
New Contributor

I have used com.apple.MCXAirPort.plist in order to disable Airport and it did work, and now I need to revert it on few machines. I have tried to push same plist with the key changed to <dict> <key>DisableAirPort</key> <false/>, but it didn't work and Airport stays disabled. Also I did make sure to exclude machine from original "Disable Airport" configuration profile. Any suggestions on how I can now enable Airport?

Thank you,

el2493
Contributor II

@lsilver , were you able ever to figure this out? I'm in the same situation as you.

We have a Managed Preference that disabled Wi-Fi, but we need to exclude one computer that already has the Managed Preference. I added the computer to the exclusions, confirmed in the Management tab of the computer (on JSS) that it doesn't have any Managed Preferences, but it still can't connect to Wi-Fi and Airport remains disabled (with the option to turn it on grayed out). I tried creating an inverted Managed Preference where in the Airport payload "Disable Airport" was set to "False," confirmed that after a while it showed up on the Management tab of the computer, but still it won't let us enable the Airport.

I've already checked through all Policies and Configuration Profiles on the computer and don't see anything else that could be disabling Wi-Fi.

Cayde-6
Valued Contributor

Once the profile is removed run the following command as admin/root

networksetup -setnetworkserviceenabled Wi-Fi On