Apple Classroom - Students show up, but as "offline" in the teachers classroom console

pmckeehan
New Contributor II

Apple Classroom - Students show up, but as "offline" in the teachers classroom console. We are using Securly SMART Pac. The students Ipad are getting the classroom profile, so that seems to be working. Any ideas? Firewall port? Smart Pac issue? I'm grasping at straws here. Thanks for your help.

7 REPLIES 7

larry_barrett
Valued Contributor

Bluetooth on?

pmckeehan
New Contributor II

Yes. I've made sure that airplan mode is OFF and Bluetooth is ON. I think it's something deeper in either the configuration profiles or a Securly SMART Pac.

beteka
New Contributor II

I see that on a regular basis... most likely that the user didn't restart his device for quite a while... just long press the Home button and the On Off Switch until you see the white Apple on a black background. Most of the time, Classroom just work fine after

ejculpepper
Contributor

Are your classes being managed by Jamf, or are they adhoc? I have seen this issue several times with our managed classes, it has always been due to the teacher's name changing which causes the EDU profile to be removed from the device.

The roster data is still tied to their old username, so I have to unassign the device from the new user and delete the user that does not have the roster data. Then, rename the old user with the roster data so that it shows their correct new name and username and assign the device to the renamed user.

On the next inventory update, the device pulls the EDU profile again and their students show online.

pmckeehan
New Contributor II

Thank you all for the responses. The issues ended up being more of a networking issue than a configuration one. I have several SSID's being pushed out by my Access Points, with slightly different security, QoS, bandwidth, etc, settings on them. The simple solution to my problem was to ensure that my teacher's iPads were connected to the same SSID as my student's iPads. (even though the SSID's are on the same VLAN, Subnet, and IP range. I digress)

Thank you all again! Much appreciated.

Ours are all on the same SSID and Vlan same security specs... still offline. All classes Bluetooth and wifi certified still offline. The strange thing is that I have 3 teachers assigned that class all three see different students off and on line ??? We validated all in "Clearpass" all the same config and all students config the same... definitely a JAMF PRO issue ... JAMF support has no clue ....

 

 

I'm seeing a similar thing and have a ticket open with Apple.

I've instructed my teachers to open settings on the offline student's iPad and tap on classroom, usually they then connect. 

 

with the students that show as offline being random and not easily reproduced it's been difficult to troubleshoot.