Apple School Manager and VPP License with adam id xxxxxxxxx has been transferred to a different VPP token

Valued Contributor II

My total Licenses for my VPP accounts (Settings>Global MAnagement>VPP Accounts) are fluctuating from the expected number to 0
tons of this in my logs:
VPP License with adam id xxxxxxxxx has been transferred to a different VPP token

and in ASM:

and for humor:


New Contributor

Same here started yesterday afternoon

Release Candidate Programs Tester

Seeing this as well.

Also purchased apps are not being added to the "Mac App Store" list & on occasion:



Same starting yesterday, everything looked good early Tuesday morning pretty much until around 6:00 AM CST or so. I only have a few of the error message adam id being transferred to a different vpp token, more of these:

[ERROR] [duledPool-6] [VPPProgramLicenseHelper  ] - Update license counts failed
com.jamfsoftware.vpp.comm.VppServiceException: Could not send request to

If it does succeed to update license counts it takes 60-80 minutes.

Release Candidate Programs Tester
PI-005694 - [VPPProgramLicenseHelper ] - VPP License with adam id xxxxx has been transferred to a different VPP token. Hi Ben, from what I can see that PI has been reported on the 5th of May 2018. I've just spoked with a our engineering team and they confirmed that there was a VPP service outage, that should generally be fixed now. To bring back license count and get rid of the error we can both: KV43rEytUIDabK94A2vx Just to recap, if we do have a VPP outage while the VPP license monitor is running, it will fail and due to the PI will not report a congruous error and then we will see license count to 0 or apps not automatically been listed in the macOS/iOS App Store Apps section in Jamf Pro I will suggest to get the VPP token renewed for the affected customers and keep an eye on those instances in the next days, when we should no more have VPP outage hopefully.

New Contributor

I talked to Apple this morning and they are working on the Error.
Their tech tried and he got the same error.
Then he sent the ticket to the engineers.
Told me to keep checking every so often to see if they have fixed it.

New Contributor

Just checked and it is working now.

Contributor III

I saw this showing up in my logs going back to the end of December and reported it to jamf after starting this discussion on the same topic...After much back and forth with jamf support this is what I got back: I spoke with an Engineer and he said not to be concerned with these lines. They are just [INFO] at this time. If they were to become errors or warnings then we would want to investigate. He believes there was additional processes that have been added into v10 to monitor for any Apps and Books type transactions. Per the screenshot you sent in, he did confirm nothing has been converted over. He also says as long as all of the licenses and apps are deploying, he sees no further reason to bring any tokens in house to investigate. Interesting that suddenly it is NOW a PI. Kind of annoyed right now...