Application Install policies not installing from Self Service... But they worked before

New Contributor III

Hi everyone-

I'm running into an issue recently, where we just upgraded from 9.91 to 9.96. One of the things that I have found, aside from the "reveal in Finder" not working in Admin PI-002981, is that the packages that I had captured and uploaded to Admin, some of them are not working anymore.

They are very simple in workflow, I move the untouched PKG into a folder on the root of the hard drive, I then send the folder up to Composer, and add a Pre-Install script which is a basic call which would look like: installer -pkg <nameofpackage.pkg> -target / in this example, I was testing with Lync and Skype For Business.

In the past, those worked like a charm, but now it is not working at all. I can see the progress bar, it completes, but the file is not present in the Applications folder. The real interesting thing is that I have tested with a few of my Self Service jobs (Firefox, Atom, Chrome), and those policies are working, others are not.

Hopefully someone can shed some light onto my dilemma.


New Contributor

What do the logs say?

New Contributor III

The logs from the JSS all say "Successfully installed", as do the logs from /var/log :(

Just re-ran one of my pkg+Script installers, and even though it says it finished, no program was installed.

New Contributor II

I had exactly the same issue. I figured out that the issue was that I had a PKG inside a DMG.
As soon as I added the PKG directly to the JSS the package installed successfully.
Not sure if this is expected.