Apps able to be deleted after iPadOS 16.1 update

New Contributor II

Hello, it seems that users are able to delete apps even when the box is unchecked to "Allow user to remove the app" on the specific app page.

We have Lightspeed relay smart agent app that we don't want deleted. iPads on iPadOS 15 work correctly, they have a profile to allow removal of apps but the relay app does not allow removal so they can't remove it. iPads on iPadOS 16 with the same config allow removal of the app.

It seems that is is all or nothing as far as app removal goes on iPadOS 16.1


Anyone else experiencing this?


Valued Contributor II

Seeing the same. Opening a support case with Apple.

Contributor II

I've seen sporadic issues with the app removal restriction not working on certain devices since the feature was released in 14.0. I had to re-deploy a configuration profile again to restrict deleting apps because random iPad would allow the student to delete the Relay app, while other devices would block the deletion. I could find no correlating reason why some would and some wouldn't.

Related to iPadOS 16.1, however, I was not able to replicate the specific issue on a test device. Device on 15.7 stated that the app could not be deleted when I tried to remove it. Updated the device to 16.1, tried to delete the same app, also prompted that it could not be removed.

Valued Contributor II

I tested this further. Non-removable apps still work in iPadOS 16.1 - it is just the UI that has changed. 15.7 did not give you the option to remove the app. 16.1 gives you the option to remove the app, however, if you try and remove it you'll get a message that your organization doesn't allow it to be removed.