AutoCasper imaging and High Sierra

New Contributor III

Is anyone else having issues with building sets off of High Sierra? The image build completes from auto dmg, and also completes from autocasper nbi, I move my netboot set around. Built my 10.13 config in Casper Admin. After imaging completes, not a single account can login. I have tried everything I can think of. I re-created my user packages from CreateUersPKG, command line scripts that work in Sierra, I even tried a composer package where I created all the users I wanted to create on this new build to no avail. Anyone else experiencing this? Only way I can login is if I remove AppleSetupDone from single user mode, but that only gets me that one user. Its not a good work around when I need to image over 60 machines to kick out the door. Thanks for any help or insight.


Valued Contributor II

CreateUserPkg isn't compatible with High Sierra. That's probably your main issue. There's a python script from Greg Neagle that takes its place.

Contributor II

No quite try, Greg Neagle has a version that works with 10.13

New Contributor III

Thanks guys.

New Contributor III

Trying to figure out how to use Greg Neagle's CreateUserPkg. Not a script wizard.

New Contributor

The link is broken. Is there an alternative place to download it? I haven't been able to find anything. Thanks!

Not applicable

we could not get createuserpkg to work so we transitioned over the pycreateuserpkg: