Bypass New Account Setup Assistant?

Levi_
New Contributor III

Hey Everyone,

I'm trying to find a way to suppress the new account setup assistant when logging into accounts for the first time. I'm currently using DEP with a pre-stage deployment profile to bypass the initial setup assistant and log in straight to the administrator account. When I create a users account, be it through Users & Groups or Jamf Connect, I'm greeted by the new account setup IE) Accessibility, Data & Privacy, Touch ID & Theme. 

Is there any way to skip this when signing into new accounts the first time?

Thank you for your help!

1 ACCEPTED SOLUTION

KyleEricson
Valued Contributor

@Levi_ 
Download iMazing Profile Editor from the Mac app store and use the built-in Skip Setup Assitant payload. 
https://apps.apple.com/app/imazing-profile-editor/id1487860882?ls=1&mt=12
2021-07-16_11-12-11.png

View solution in original post

7 REPLIES 7

bartlomiejsojka
Contributor
Contributor

I believe @aaronpolley has the most recent take on it in the „blogosphere” with macOS Setup Assistant Preferences (Skip Screens) blog post 👍🏼.

KyleEricson
Valued Contributor

@Levi_ 
Download iMazing Profile Editor from the Mac app store and use the built-in Skip Setup Assitant payload. 
https://apps.apple.com/app/imazing-profile-editor/id1487860882?ls=1&mt=12
2021-07-16_11-12-11.png

View solution in original post

Hi Kyle,

I've just tried ou this iMazing profile Editor. It didn't skip the Siri setup, but did do the others. I even signed the configuration profile.

I had gotten another one for Siri from Rich Trouton.
https://github.com/kylejericson/JAMF/blob/master/com.apple.SetupAssistant.plist 

Levi_
New Contributor III

Thank you @bartlomiejsojka. I am going to investigate this route for Big Sur and see what happens as this will skip the new account setup specifically. 

Hey @KyleEricson, I'm currently skipping all the OOB setup assistant, do you know if the iMazing Editor will conflict with that?

KyleEricson
Valued Contributor

No shouldn't be an issue @Levi_ 

Levi_
New Contributor III

@KyleEricson Thank you. When I tried it without signing the profile it failed. Guessing even though the cert is signed by Jamf when deploying it had an issue with it. I signed it and it worked for the next account I tried. I'm going to test it out some more but it seems like this will work so far.