Casper Admin prefs "Modification Date"

donmontalvo
Esteemed Contributor III

After wasting time and losing hair, updating packages, testing and seeing the same log errors, redoing them, testing them, same errors....arghhh!!!!...well, I discovered that Casper Admin's sync preferences defaults to "File Size" which I don't remember ever having to change.

Apparently EMC Isilon shares don't like it. So Casper Admin can't tell that we've updated some packages. We've never had to change the default setting, but now we need to make sure it's set to "Modification Date" for sync to work.

How do you guys have your Casper Admin prefs set? Do you change it from it's "File Size" default? What kind of shares are you using?

TIA
Don

--
https://donmontalvo.com
6 REPLIES 6

Kumarasinghe
Valued Contributor

Sync Preferences: File Size (Default)
SMB shares on a VM (direct attached LUNs)

dpertschi
Valued Contributor

Wow. I've completely overlooked that preference, and yes it's set to Size.
I've always been under the impression Date was the default criteria. I can't say it's caused me any trouble, but...

donmontalvo
Esteemed Contributor III

NM

--
https://donmontalvo.com

jwojda
Valued Contributor II

I've been setting modification date for quite some time. Still not perfect (system always is recopying packages that exist already), or not copying packages at all that never existed, even though it says it did.

donmontalvo
Esteemed Contributor III

@jwojda, I'm pretty sure we've always had it set to Modification Date, but I also remember it being the default. I would never, ever leave it set to File SIze.

If we have to update a PKG by editing one of it's scripts and changing a comma to a semi-colon, Casper Admin won't have a clue the PKG was updated, so it won't get replicated.

JAMF, has the default changed from Modification Date to File Size?

We are on 8.64

Don

--
https://donmontalvo.com

Kumarasinghe
Valued Contributor

We have a Robocopy script that runs periodically to do the automatic syncing as well.