Clear OS X Self Service Notifications?

azbikowski
New Contributor

I just noticed someone has 115 notifications from Self Service. Is there a way to automatically clear or expire the notifications after a period of time that I've missed somewhere along the way?

4 REPLIES 4

mm2270
Legendary Contributor II

I'm not sure if this will work, as it might get reset by the jamf binary, or if its even the same thing, but you can try running the following command to see if it clears them

defaults write ~/Library/Preferences/com.jamfsoftware.selfservice.plist SelfServiceBadgeNbr -int 0

That key seems to hold an integer on the number of badge items the Self Service application displays, which I think should correspond to the number of Notifications inside Self Service. I have not specifically tested this theory though, so uncharted territory.
But, give it a try and see. Worst that could possibly happen is it won't work, or you may need to trash the plist and have Self Service generate a new one if it gets too mucked up. Best that could happen is that it will work, right?

EDIT: I meant to also say, you aren't missing a setting. To my knowledge the way they get cleared is by the user opening SS, going into the Notifications section and clicking the little "x" button next to each one to remove them. No JSS setting is there to auto clear them after a set period of time.

azbikowski
New Contributor

Deleting ~/Library/Preferences/com.jamfsoftware.selfservice.plist did it, the defaults command didn't. Thanks.

mm2270
Legendary Contributor II

Ok, good to know. I didn't think just deleting it would actually work. I wonder if it will end up reappearing though the next time the jamf binary does its check in. If the notifications do resurface, post back.

emily
Valued Contributor III
Valued Contributor III

Resurrecting an old thread, my apologies, but I ran into this at my new job and wanted to note that disabling the option in the JSS, then running recon appears to do the trick. I actually ran manage first and didn't see the notifications go away. Then I ran recon and didn't see it go away. Followed it up with policy and finally after that it disappeared, though I wouldn't be surprised if recon really fixed it but I was impatient.