Composer 10.28 - Couldn't communicate with a helper application

snowfox
Contributor II

Hi All,
I've never had a problem before using composer to package apps until version 10.28. When packaging a drag and drop app such as Krita or Blender, Composer has started displaying this error message during the 'Build as PKG' build process - Couldn't communicate with a helper application.

I've never seen this before, it's doing it on a clean install of Catalina 10.15.7 and on a different machine with an upgrade to Big Sur 11.2.3.

It will package VLC successfully but not Krita or Blender.
It will create DMGs ok for all three.

All three are given the same owner/group & permissions before creating a new PKG. Root, Admin and 755.

Has anyone else encountered this issue and were you able to resolve it?
Thanks for any info!

4e4c771939ca4f07a51c57a19a181dfc

1 ACCEPTED SOLUTION

Reiven
New Contributor II

I was having the same issue. I checked the online manual and found that they added a new Preference for executable type I found that to be causing the issue. I can only hazard a guess that it is not detecting the executable type correctly. I went into Preferences and changed "Executable Types in PKGs:" to "One or More executables require Rosetta" from "Automatically detect executable types" it fixed the error.
119de55680e7482fb179735028df57b0

View solution in original post

10 REPLIES 10

Reiven
New Contributor II

I was having the same issue. I checked the online manual and found that they added a new Preference for executable type I found that to be causing the issue. I can only hazard a guess that it is not detecting the executable type correctly. I went into Preferences and changed "Executable Types in PKGs:" to "One or More executables require Rosetta" from "Automatically detect executable types" it fixed the error.
119de55680e7482fb179735028df57b0

View solution in original post

Hayden_Webb
New Contributor II

Thank you!

snowfox
Contributor II

Many thanks @reiven
That worked. Looks like the auto detect isn't detecting intel and universal binaries properly.

Kapil
New Contributor III

@Reiven You save my day... Thanks a lot Buddy

fernando_gonzal
Contributor

@Reiven this worked for us thanks so much!

tcandela
Valued Contributor

got the same error and just made the same change in Composer and now it looks to be processing and just completed.

joshuaaclark
New Contributor III

Ditto. Thanks-a-lot!!!

chrisB
Contributor

Thumbs up - thanks!

david_yenzer
Contributor II

Thanks! We are digging into M1s now and that was literally a 60 second fix for our issue!

Ekachai
New Contributor

Thanks!