computers losing name in sharing

New Contributor

We are having an issue with our Mountain Lion image, using Casper 9.7. The computers seem to image correctly, then after a restart the name disappears from sharing and the machine shows up in Casper as localhost. Due to this problem, I have 160 machines that are all calling themselves localhost, and they are not pulling down the proper policies. We are experiencing a lot of connection issues, because everything is managed through Casper. Has anyone else experienced this recently? I searched the knowledge base and found some posts from a few years ago, but none of them seemed to be exactly what we are experiencing, and the scripts I tried didn't help. Is there a script or setting we can use to force it to use the name used to bind it to Active Directory, so we don't have to manually go and fix each one?


Contributor II

Have you tried using the scutil command in your script? Also, how are you naming your computers (serial number, pre/suffix/etc)?


We run a policy that resets the computer names to match JSS0e259e084c754e0a99d504aab75972a8
We trigger on everything.

Valued Contributor II

if you are using a loginwindow policy there is a known bug on stuff older than 10.10.2 that if you are enforcing the hostname in the loginwindow policy it will change one of the pieces of the hostname to localhost which is the piece that the recon happens to report. I just disabled that in my policy for a while or wrote a tool to reset the hostname when it was wrong but every time the user closes the lid and opens the lid the hostname gets changed again so it was running a lot.