Configuring DEPNotify to run via Self Service

sslavieroGSMA
New Contributor III

I'm confused about how to get DEPNotify to run correctly (or I should say the way I want it to run)... I would like this to run from Self Service to cover both DEP and non-DEP computers, all handled by my IT Team.

Here's my thought process - We're using Jamf Connect Login(JCL) (tried to use DEPNotify built into JCL, but thought that I need to cover the NON-DEP computers). IT logs the user in via JCL > opens up Self Service > clicks "Install" on the Build Process icon > off goes DEPNotify and deploys everything I need it to.

So here's what I've got in place currently:
I've packaged up DEPNotify and a Logo package to a Policy to install via a trigger.
I've got a DEPNotify script (not sure if correct...) in a Self Service Policy to click to start the build process.

Contents of script in order:
setup variable to call Jamf binary
install DEPNotify by calling the Policy trigger
DEPNotify commands to set logo, window title, main title, main text, determinate off, window not movable.
command to launch DEPNotify: open -a /Applications/Utilities/DEPNotify.app - not sure if it's correct, was going as running as root via Jamf...
Set Determinate to 4 (for small scale testing)
Start going through Status steps to installing apps > calling Jamf Binary event triggers to install at each step.
Once done, then Quit command.

Problem is DEPNotify doesn't even show up... I know everything is installing as it should be as I have User Interactions showing when installing/installed.

Not sure what I'm doing wrong - Please HELP!!

2 REPLIES 2

stevewood
Honored Contributor II

@sslavieroGSMA

Change the method you are launching DEPNotify to using the following code:

echo "Creating DEPNotify LaunchAgent"
/bin/echo "<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Label</key>
    <string>com.corp.launchdepnotify</string>
    <key>ProgramArguments</key>
    <array>
        <string>/Applications/Utilities/DEPNotify.app/Contents/MacOS/DEPNotify</string>
        <string>-fullScreen</string>
    </array>
    <key>RunAtLoad</key>
    <true/>
</dict>
</plist>" > /Library/LaunchAgents/com.yourcompany.launchdepnotify.plist
##Set the permission on the file just made.
/usr/sbin/chown root:wheel /Library/LaunchAgents/com.yourcompany.launchdepnotify.plist
/bin/chmod 644 /Library/LaunchAgents/com.yourcompany.launchdepnotify.plist

## Now launch DEP Notify
/bin/launchctl load /Library/LaunchAgents/com.yourcompany.launchdepnotify.plist

That should go in after you've set all of the DEPNotify settings. We use that to launch provisioning via Self Service after running some cocoaDialog dialogs to gather information from the techs for non-DEP devices.

We also use DEPNotify for a long Adobe installation process through Self Service as well, we just don't use the -fullScreen switch for that one.

sslavieroGSMA
New Contributor III

Thanks @stevewood - someone on Slack mentioned the use of special characters might have something to do with it.

My script was littered with !'s everywhere...

Got it working now, just need to expand it.