CS5.5 install on imaging

DavidN
New Contributor III

Has anybody successfully installed CS5.5 when imaging? We're using an SMB share, have packaged the .pkg inside of a dmg per this article.

https://jamfnation.jamfsoftware.com/article.html?id=161

DMG is in the waiting room and does successfully mount, but the Adobe pkg installer fails everytime.

Has anyone gotten this to work at imaging time?

Thanks,

Dave N

6 REPLIES 6

rob_potvin
Contributor III
Contributor III

I have this problem it could be your permissions on /Library/ColorSync/Profiles

I would check as CS 5 would fail for me and it was because of this.

Cheers

rob_potvin
Contributor III
Contributor III

I have this problem it could be your permissions on /Library/ColorSync/Profiles

I would check as CS 5 would fail for me and it was because of this.

Cheers

donmontalvo
Esteemed Contributor II

A good place to post your logs...Adobe installer dev engineers monitor this forum:

http://forums.adobe.com/community/download_install_setup/creative_suite_enterprise_deployment

Don

--
https://donmontalvo.com

DavidN
New Contributor III

Log file attached. It DOES work when installed manually, or through self service. Only fails when trying to install at image time.

Jun 20 11:09:36 D32853 installer[14038]: -[IFDInstallController(Private) _buildInstallPlan]: file://localhost/Library/Application%20Support/JAMF/Downloads/CS5.5DPSerializedWithUpdates02_09_13_Install.pkg "PKJaguarPackage <file://localhost/Library/Application%20Support/JAMF/Downloads/CS5.5DPSerializedWithUpdates02_09_13_Install.pkg>"
Jun 20 11:09:36 D32853 installd[14055]: PackageKit: Extracting file://localhost/Library/Application%20Support/JAMF/Downloads/CS5.5DPSerializedWithUpdates02_09_13_Install.pkg (destination=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/Cleanup At Startup/PKInstallSandboxManager/1.sandbox/Root, uid=0)
Jun 20 11:09:36 D32853 installd[14055]: PackageKit: Executing script "./preinstall" in /Library/Application Support/JAMF/Downloads/CS5.5DPSerializedWithUpdates02_09_13_Install.pkg/Contents/Resources
Jun 20 11:09:36 D32853 installd[14055]: ./preinstall: AAMEE Installer : Working directory is /Library/Application Support/JAMF/Downloads/CS5.5DPSerializedWithUpdates02_09_13_Install.pkg/Contents/Resources
Jun 20 11:09:36 D32853 installd[14055]: ./preinstall: /Library/Application Support/JAMF/Downloads/CS5.5DPSerializedWithUpdates02_09_13_Install.pkg/Contents/Resources/preinstall: line 115: 14074 Bus error: 10 "$WD/AdobeDeploymentManager" --optXMLPath="$WD/optionXML.xml" --setupBasePath="$WD/" --installDirPath="$2" --mode="install"
Jun 20 11:09:37 D32853 installd[14055]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “CS5.5DPSerializedWithUpdates02_09_13_Install.pkg”." UserInfo=0x7fc6d21a4740 {NSFilePath=./preinstall, NSURL=file://localhost/Library/Application%20Support/JAMF/Downloads/CS5.5DPSerializedWithUpdates02_09_13_Install.pkg, PKInstallPackageIdentifier=com.adobe.Enterprise.install.3FFC04DA-8739-4FDA-9410-9B5E6329347A, NSLocalizedDescription=An error occurred while running scripts from the package “CS5.5DPSerializedWithUpdates02_09_13_Install.pkg”.} { NSLocalizedDescription = "An error occurred while running scripts from the package U201cCS5.5DPSerializedWithUpdates02_09_13_Install.pkgU201d."; NSURL = "file://localhost/Library/Application%20Support/JAMF/Downloads/CS5.5DPSerializedWithUpdates02_09_13_Install.pkg";
Jun 20 11:09:37 D32853 installer[14038]: install:didFailWithError:Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “CS5.5DPSerializedWithUpdates02_09_13_Install.pkg”." UserInfo=0x7fab0ab45a90 {NSFilePath=./preinstall, NSURL=file://localhost/Library/Application%20Support/JAMF/Downloads/CS5.5DPSerializedWithUpdates02_09_13_Install.pkg, PKInstallPackageIdentifier=com.adobe.Enterprise.install.3FFC04DA-8739-4FDA-9410-9B5E6329347A, NSLocalizedDescription=An error occurred while running scripts from the package “CS5.5DPSerializedWithUpdates02_09_13_Install.pkg”.}

rob_potvin
Contributor III
Contributor III

Also when making your package, maybe select continue on errors? Also you are not putting any AIR apps or installers in that package right?

DavidN
New Contributor III

Select continue on errors is checked. Air apps and installers are deployed separately.

Package works just fine when installed manually, or from command line. After calling support we determined the best course of action was to have it install upon logout, which works just fine.

I just put up this post because I have not seen anyone anywhere getting this to work during the imaging process and was hoping someone has.