Disabling CarPlay Mode Jamf

abala
New Contributor

Hi , Clinical app devices are Going into CarPlay Mode when the user has been walking around with the device. Would you able to advise me how to disable CarPlay Mode in Jamf Configuration Profiles--Restrictions.

Many thanks

f572fdf6e2f14f53bfc9c5a20a57a8f6

8 REPLIES 8

ooshnoo
Valued Contributor

There is no option to do such a thing. I suggest you provide more details as CarPlay should not start unless connected to a compatible head unit.

mporter
New Contributor II

Just curious do you mean AirDrop? CarPlay doesn't startup unless it's paired with a car headunit.

kevinwilemon
New Contributor III

Like mentioned, CarPlay doesn't start unless connected to a supported headunit, but do you mean Do Not Disturb is being enabled when they're moving around? The "Do Not Disturb While Driving" feature can only be manually turned off on the device (Settings >> Do Not Disturb >> Do Not Disturb While Driving") and I don't believe there is a way to disable it via config profile. Surprised it would enable from walking, though. My experience is you'd need to move pretty fast for the M-chipset to think you're in a car.

larry_barrett
Valued Contributor

In the right building your location could be bouncing around.

Anyways, screenshots or it didn't happen.

mainelysteve
Valued Contributor

@larry_barrett Seconded. Screenshots or it didn't happen. If it is come see me. My Ridgeline doesn't have it.

abala
New Contributor

Hi all please see the screenshot

mainelysteve
Valued Contributor

And the winner goes to @kevinwilemon . Either DNDWD is very sensitive or you have some really fast walkers.

georgecm12
Contributor III
Hi all please see the screenshot

I could be wrong, but the image in the top post appears to be a pane that appears during setup assistant.

DNDWD, when it kicks in, is just a simple notification on the lock screen that reads "DO NOT DISTURB WHILE DRIVING - You will not receive notifications while you are driving." You can tap on that notification to bring up a button that says "I'm Not Driving."

I'm not yet current on my JSS, but on mine, I don't see an option to skip a DNDWD pane in a prestage, unless it's grouped under "new feature highlights." You could try that - create a prestage for the device, tell it to skip "new feature highlights," and reset the device to see if that DNDWD pane goes away.