EndNote X8 w/ Cite While You Write deployment

rcarey
New Contributor III

Goal: deploy EndNote X8 so that End Users can open Word and the Cite While You Write plug-in will already be configured without needing to do anything.

I've used Composer a few different ways, and the outcome seems to always be the same: Application installs, but plug-in has to be manually configured. I even tried to do a snapshot from before installing the application, to going all the way through the "Customize" portion and verifying Word opens with working plug-in. I've made dmg and pkg files, but I never get the intended outcome.

Maybe I need a script to run following the install? But alas, I lack the scripting skills/knowledge.

Any thoughts or advice?

1 ACCEPTED SOLUTION

dsavageED
Contributor III

We use:

#!/bin/bash

WordMajVersion=`defaults read "/Applications/Microsoft Word.app/Contents/Info" CFBundleShortVersionString | awk -F "." '{print $1}'`
WordMinVersion=`defaults read "/Applications/Microsoft Word.app/Contents/Info" CFBundleShortVersionString | awk -F "." '{print $2}'`

case $WordMajVersion in
15)  echo  "Word version 15.xx, need to confirm it is above 15.24"
    if [ ${WordMinVersion} -ge 24 ]; then
        rm -dfR /Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word/EndNote CWYW Word 2016.bundle
        #Copy the new one
        ditto "/Applications/EndNote X8/Cite While You Write/EndNote CWYW Word 2016.bundle"  "/Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word/EndNote CWYW Word 2016.bundle"
        chown -R root:admin "/Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word" 
    fi
    ;;
16) echo  "16.X this is the insider build"
        rm -dfR /Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word/EndNote CWYW Word 2016.bundle
        #Copy the new one
        ditto "/Applications/EndNote X8/Cite While You Write/EndNote CWYW Word 16.bundle"  "/Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word/EndNote CWYW Word 16.bundle"
        chown -R root:admin "/Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word" 
   ;;
*) echo "**** Microsoft Word is not a compatible version! ****"
    exit 1; # Fail the install as it won't patch correctly
   ;;
esac

As Office 2016 could be on one of two versions unfortunately.

View solution in original post

3 REPLIES 3

Look
Valued Contributor III

One definite issue with this is that there are several different versions of CWYW and the correct one is installed based on what version of Word Endnote detects on the machine.
The location these go to varies as well as Microsoft has moved things around several times.
The current location for latest version of office looks to be:

"/Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word/EndNote CWYW Word 16.bundle"

The various versions available are usually in:

"/Applications/EndNote X8/Cite While You Write"

dsavageED
Contributor III

We use:

#!/bin/bash

WordMajVersion=`defaults read "/Applications/Microsoft Word.app/Contents/Info" CFBundleShortVersionString | awk -F "." '{print $1}'`
WordMinVersion=`defaults read "/Applications/Microsoft Word.app/Contents/Info" CFBundleShortVersionString | awk -F "." '{print $2}'`

case $WordMajVersion in
15)  echo  "Word version 15.xx, need to confirm it is above 15.24"
    if [ ${WordMinVersion} -ge 24 ]; then
        rm -dfR /Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word/EndNote CWYW Word 2016.bundle
        #Copy the new one
        ditto "/Applications/EndNote X8/Cite While You Write/EndNote CWYW Word 2016.bundle"  "/Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word/EndNote CWYW Word 2016.bundle"
        chown -R root:admin "/Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word" 
    fi
    ;;
16) echo  "16.X this is the insider build"
        rm -dfR /Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word/EndNote CWYW Word 2016.bundle
        #Copy the new one
        ditto "/Applications/EndNote X8/Cite While You Write/EndNote CWYW Word 16.bundle"  "/Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word/EndNote CWYW Word 16.bundle"
        chown -R root:admin "/Library/Application Support/Microsoft/Office365/User Content.localized/Startup.localized/Word" 
   ;;
*) echo "**** Microsoft Word is not a compatible version! ****"
    exit 1; # Fail the install as it won't patch correctly
   ;;
esac

As Office 2016 could be on one of two versions unfortunately.

View solution in original post

rcarey
New Contributor III

Appreciate both responses. My initial testing with that script worked brilliantly. Will keep testing throughout, because at the very least I can still install by hand, but boy oh boy is it nice to just have it deploy all in one pass.

Thanks for the help!