Export of Populated Smart Group is Empty

jwiswell
New Contributor II

I've built some Smart Groups around if specific configuration Profile Names exist (or don't) on machines.

They work great in the JSS, but when I go to export their memberships all I get is a header row. Other Smart Groups export fine, it just seems to be unique to the ones with Profile Name Criteria. We're running v9.99.

e4b6f308a21c4cd8817c68557ed178e0
90f687a6089947cfa2efb0e26ade1fe7
c9361532031a45769d661843a868bb13

13 REPLIES 13

jwiswell
New Contributor II

Update: I've got a ticket open with support for this issue (they were able to replicate it), and it's being run up the chain to find a resolution. In the meantime I'm copying and pasting from the browser into Excel to get my export.

jamesandre
Contributor

I've got this too. If I select "Computers" as the "Choose the inventory item on which to base your results" then I get a populated CSV, but if I choose "Smart Group" I only get the header.

Edit: If I remove the criteria "Smart Group - All Managed Machines" then it exports OK.

ryan_mccullough
New Contributor

Did you guys ever get this figured out? I'm experiencing the same thing on 10.7.1 exporting from a smart group. Just a header row.

surajitbapan
New Contributor

Even I have experienced the same thing today, I am using jamf pro 10.7

diradmin
Contributor II

Observed under 10.7.1 as well.

Currently working with support in an attempt to identify which PI specifically is impacting us (as there are apparently multiple relating to this issue).

damienbarrett
Valued Contributor

I just saw this happen on Friday also. I"m running 10.7.1.

scottb
Honored Contributor

Ironically, I saw this too on Friday last!
Was sure I was doing something wrong - but good to know others see it too. I think.

tyler_sumner
New Contributor

This is a known issue that we are currently working on to fix.

A good workaround is to do an Advanced Inventory Search with the criteria being the Smart Group we want the data for. We then can export the search with the export button in the bottom right corner. I would suggest saving the Advanced Search if you run a lot of reports.

diradmin
Contributor II

@tyler.sumner These "workarounds" are beginning to feel like permanent workflows for Product Issues that go years without resolution.

Thank you for the suggestion with Advanced Searches for those that might not have been aware. However, I think I speak for us all when I say we'd much rather know when this issue will simply be resolved?

ryan_mccullough
New Contributor

@tyler.sumner I tried your workaround but I'm still getting an empty spreadsheet with a header row only. If I'm following correctly I created a second smart group with the criteria being the first smart group--then exporting a CSV file from that?

leungn
New Contributor II

I just ran into this bug on JSS 10.8.0. For me, it seems specific to smart groups with Application Version 'matches regex' criteria. I created a few other new smart groups to test, and they export just fine. The Advanced Inventory Search workaround does get me the report results I need.

diradmin
Contributor II

Here is the PI information received from Jamf Support relating to this issue:

Issue Summary
PI-006274 - No Data When Exporting Smart Computer Groups

Our apologies it does look like Product Issue PI-006274 - No Data When Exporting Smart Computer Groups by Computer. This is listed as closed and verified and is fixed in our upcoming version of 10.9.0

scottb
Honored Contributor

Well, I guess 10.9 is better than 11.0 ;)