Force MDM Web Clip to open in Google Chrome?

dstranathan
Valued Contributor II

I manage a Web Clip for a team of engineers who use a CMDB solution (ServiceNow) for checking industrial & scientific equipment in the field. They do this on iPads using Safari. The CMDB solution is a cloud-based web interface, no third-party apps are required. Basically, I use MDM to push-out a Web Clip that tells Safari to open a specific private URL on the engineers iPads.

We have realized that Safari renders the ServiceNow web interface incorrectly at times. Engineers are complaining of horizontal scrolling issues, zombied drop-down menus, etc. As of iOS 8.1.3, the issues are still not resolved. Both Apple and ServiceNow are aware of my issues.

The good news is that we have discover that Google Chrome on iOS doe not exhibit the rendering issues. Thus, there has been discussion to pull the Safari Web Clip via MDM and push-out a new Web Clip that will force the engineers to use Google Chrome instead. Google Chrome is a managed app, so pushing our Chrome will be easy.

I was told by a ServiceNow support technician that he has seen customized Web Clips with a specific prefix that iOS will recognize to hand-off the URL to the Chrome browser rather than Safari.

I'm not looking to alter Safari as the iOS default browser, I just want this one particular Web Clip to open in Google Chrome, not Safari.

Does anyone have any experience with such a configuration?

Thank you

11 REPLIES 11

davidacland
Honored Contributor II
Honored Contributor II

You can add a Web Clip that starts with "googlechrome://" followed by the web address.

It launches in Safari and then redirects to Chrome but I suspect that will be as close as you're going to get.

dstranathan
Valued Contributor II

Thanks @davidacland.

I had no idea it was that easy. Much appreciated.

brandonusher
Contributor II

We had the same issue in our District with Haiku Learning not working in Safari.

At first I had made a redirect page and linked the webclip to that thinking that solved the issue. Turns out Safari is awesome and leaves the tab open. Once you re-open Safari, BOOM haiku opens again in Chrome.

So, word to the wise: Don't do it the way I did. What @davidacland said is what we are doing currently and it works perfectly

wmateo
Contributor

is there a way to force it to open in Safari? some users have Chrome as their default browser, and we have apps specifically tailored to Safari @usher.br (by the way I love all your songs!)

brandonusher
Contributor II

@wmateo How are they setting their default browser to Chrome on a Mobile Device?

dugnl
New Contributor III

How do you get this to work with an HTTPS? that method works perfectly for a non https site. Putting googlechrome://https://urladdress actually leaves out the : after https so it can't find the page. leaving out https entirely, makes it think it's not valid webpage (would work for non https sites).

mhegge
Contributor II

Leave out the https entirely worked for me:

googlechrome://urladdress

markvinten
New Contributor

For other people who stumble across this, there are two iOS schemes:

googlechrome:// --- this is http
googlechromes:// --- this is https

See https://developer.chrome.com/multidevice/ios/links for more information.

nwlarivij
New Contributor

this works great for Chrome but has anyone bee able to get this to work with Microsoft Edge browser on iOS?

hsekiv
Contributor

microsoft-edge-http:// or microsoft-edge-https://
Found it here
https://stackoverflow.com/questions/51025950/is-there-a-url-scheme-to-open-a-website-in-microsoft-edge-on-ios

user-efNFoPXigQ
New Contributor

Hi all! Do you have the firefox switch? Can't find it anywher!