How to disable auto launching "Wacom Desktop Center" app during user's first login

wdoty
New Contributor

Screen Shot 2021-07-08 at 8.07.54 AM.pngHey Everyone,

Does anyone know how to disable the "Wacom Desktop Center" app from auto launching during a user's first login?

(I don't remember having this issue last year when setting our computer lab iMacs at my community college.)

25 REPLIES 25

smolyeet
New Contributor III

is there a launch daemon or agent for this?

wdoty
New Contributor

I couldn't find any for this.

Howard_Trevor
Contributor

I just deleted the launch agent plist files and it worked. Desktop center no longer pops up first thing, still opens up fine when clicked on without issues, seems all good.

What is the path to those launch agent plist files?

Howard_Trevor
Contributor

/Library/LaunchAgents

There were 3 plists in there for me. I just removed all three because I really didn't feel like testing 1 by 1 right now and it worked fine. There are also 2 in the /Library/LaunchDaemons that might provide the same result if removed. Again, haven't tried it. These worked on Catalina, don't even want to think about Big Sur at the moment but im sure its similar. 

Unfortunately after deleting those plist files, it did suppress the Wacom Desktop Center from opening at new user login, BUT it broke the Wacom Desktop Center in the process. We plugged in a Wacom Tablet and the tablet is unresponsive. Then we tried opening the Wacom Desktop Center app and we get the spinning wheel of death.

Howard_Trevor
Contributor

Really? I just tested 10 machines in a lab of 30 and didn't have any issues with any of them. Tablet was recognized right away and functioned identically to a machine next to it that still had plist files in place. Rebooted and tested a few different times with no issues. Different result from removing the daemon instead of the agent? 

thuanphuoc
New Contributor

It's seem like there's no way to disable that notif

Minomis
New Contributor II

There is no way to disable the Wacom Experience Program first launch dialog using supported methods.
Deleting the LaunchAgents will break the app launch process after a logout, I can confirm this on the latest version.

As this popup is a massive headache, I had to resort to creating a LaunchDaemon that looks for the Wacom Desktop Center process at every user login, this then kills it once which creates the required files so Wacom no longer presents this dialog for that user. Big hack but its better than having the dialog appear at every login, boot load times reduce considerably too.

Can you share how you did this?  I need to suppress this popup in our labs and I'm not familiar with creating a LaunchDaemon. 

NickWilliams
New Contributor III

I think I might finally have worked this out (thank you Jamf Composer). The file which controls the behaviour seems to be:

~/Library/Containers/com.wacom.DataStoreMgr/Data/Library/Preferences/.wacom/persistent.plist

There are a set of key pairs in there which you need to modify:

<key>Analytics_On</key>
<string>NO</string>
<key>PEN_SECOND_RUN</key>
<string>YES</string>
<key>TOUCH_SECOND_RUN</key>
<string>YES</string>

 

i need to do a load more testing around this, and script the fix (I'm going to generate the file into "/System/Library/User Template/en_GB.lproj/Library/Containers/com.wacom.DataStoreMgr/Data/Library/Preferences/.wacom" so that the Experience Program is already opted-out of for all new logins on our shared machines) but hopefully this might help someone else manage their nightmare.

If it's of any interest, during my prodding about I also found that these files have useful looking stuff in them:

~/Library/Group Containers/EG27766DY7.com.wacom.WacomTabletDriver/Library/Preferences
com.wacom.wacomtablet.prefs <--search for "WDCAutoStart"
com.wacom.Wacom-Desktop-Center.plist <--search for "loggedInAtLeastOnce"

This sounds promising but I don't think you're supposed to edit the user template any more, I wonder if there's a way so use this without doing that. Out student's home folders get cleared off our lab machines every day so I need to find a way to sort this out at each and every login not as a one time thing unfortunately 😞

 

I currently have a small timer at the end of the main login script waiting up to 10 seconds for it to appear then killing it but I'm not happy with that.

You could always write a script that generates the file for the current user at login? That should get hopefully round the problem. Editing the default user profile is definitely a bit risky these days (updates can wipe it all out occasionally) but as a quick and dirty solution it's still hard to beat. 

I could but the problem is all these things turn into a race condition.

There are 3 launch agents for WaCOM one of which is com.wacom.DataStoreMgr.plist so I'm presuming that's what causes the thing to appear.

Launch agents all load in an asynchronous and somewhat unpredictable fashion when someone logs in so the question is where you put the script to create the file before that launch agent causes the thing to appear. I could add it into our main login script (which creates some other files anyway) but there's no way to guarantee that it would do that before the other agent ran that I know of.

snowfox
Contributor III

Screenshot 2021-08-16 at 16.49.26.png

This is working for me.

Steps:

Install the Wacom Tablet Driver PKG. (Additional - Use the Jamf PPPC Utility to add the tablet driver to the Input Monitoring section by selecting - 'Allow standard users to approve access'. This will get rid of the driver security error prompt every 15 seconds or so.)

Configure Wacom Desktop Center how you want it to be i.e. Untick AutoStart and click OK on the Customer Experience button without the opt-in button ticked (default setting).

Open Finder and navigate to /Library/User Template/Non_localized/ and drag the Library folder listed there over to Composer, as in above screenshot.

Now navigate to the 2 file locations above in your User Profile hidden 'Library' folder (GO Menu / Hold ALT or Option Key to show hidden Library folder).

The .wacom folder wont appear unless you press SHIFT + Command + . in Finder to show hidden system files.

Drag the five files listed above over to the main Composer window (make sure the folder paths are the same as above.) You'll have to move the 'Group Containers' and 'Containers' folders from your User Profile 'Library' folder path to the Default User Template 'Library' folder path. Then delete the remaining parent folders listed from your User Profile.

(Clear as mud I know. Look at the screenshot above and make sure your folder paths are the same as mine.)

Once all that's done, you need to adjust the file and folder permissions before building the package.

Select the Library folder at the top

Folders - Root : Wheel : 755

Files - : Root : Wheel : 644

Cog Icon (Bottom right)

Apply Permissions to Library and All Enclosed Items

This will set everything to 755, for folders and files.

Apply Owner and Group to Library and All Enclosed Items.

This will set everything to Root : Wheel, for folders and files.

Be sure to change the file permissions afterwards to 644

Click Build as PKG (Choose save location.)


If you want to turn off Wacom Desktop Center notifications - the bundle ID is com.wacom.Wacom-Desktop-Center

 

whiteb
New Contributor III

Thank you for this write-up. Took quite a while to get it exactly like yours, but I finally did it.

How did you deploy the preferences.pkg with the driver.pkg? Preferences needs to run after the driver gets installed I would imagine. I don't need to fill user templates or anything for the preferences? (Think that's only for .dmg's).

I ran the preferences.pkg on my machine that has Wacom drivers installed to test. I checked auto-start in the desktop center, then closed the app. Ran the preferences.pkg after, then launched the desktop center again and auto start was still checked. 

snowfox
Contributor III

Hi,

What you did above wouldn't change the settings for an already existing account.

Yes you install the drivers pkg first and then the configure settings pkg.

No you don't need to tick fill user template or anything like that.

The configured settings are copied into the default user template folder under the Library folder.

A new user account will apply the settings when it is being generated for the first time.

An already created and logged in user account has already created its user profile so it wont pick up the new settings.

So your local Admin account will still load the Wacom Centre at login.

Create a new standard user account in Users & Groups.

Log in with that.  As it is logging in for the first time, it will pull the files and folders from the Default User template and configure the settings of the Wacom software.

If you coped what I did above, the new settings should already be applied to the users profile by the time they get to the desktop and the Wacome Centre should not auto load.

I was stuck for time and this is the way I did it.  If someone comes up with a better way I am open to suggestions.

 

Screenshot 2022-01-09 at 17.25.26.png

iTechSupportInc
New Contributor III

Thanks @SnoFox!  Any ideas on suppressing the Desktop Center on a login that's created as part of a pre-stage enrollment?  I followed your directions and the preferences are being installed, but since the user already exists by the time this package runs, the user that went through the enrollment still sees the Desktop Center... 

samuellarsson
New Contributor III

@iTechSupportInc 

but since the user already exists by the time this package runs, the user that went through the enrollment still sees the Desktop Center... 

We have the same issue here, the home folder template method does not work because most users who use the computers in this lab already have their profiles created. Maybe the only way to remedy the problem is to first change the home folder template for new users like above, and then modify all of the user profiles that have already been created.

luke_jaeger
Contributor

this works for me on Monterey:
/usr/bin/defaults write com.wacom.Wacom-Desktop-Center.plist cacheAutoStart false

the preference is set per user, so make sure you set this to 'Login' trigger and 'Once per user per computer'

luke_jaeger
Contributor

... of course, the Wacom Desktop Center tends to launch before policies triggered by user login finish running. So this turns out to be a hit-or-miss solution.
What _actually_ works is to create a Software Restriction for Wacom Desktop Center in JSS, unless you need it for some reason. As far as I can tell its only purpose is to annoy the users. This is a bit of a sledgehammer solution but it does work.

iTechSupportInc
New Contributor III

Thanks!  I added that to my DEPNotify script and while the WDC software does launch initially, it does not on subsequent logins, so at least we don't have to explain to almost 1000 users how to disable the aggravating thing.  We can't restrict it because there is a legit use for it.

in that case, disabling it on second login (and following) may be the best you can do. You may also need to set loggedInAtLeastOnce to 'true'

 

kacey3
Contributor

I tested both of the preference lines as a local preference and they worked fine. Was hoping to set it up as a global Configuration Policy, but it looks like it doesn't apply correctly that way. Kind of a bummer.

Upon further testing, I'm not fully convinced that it works at all. Maybe my testing environment is flawed.