How to upgrade OpenSSL with 3.0.7 version via JAMF for all enrolled endpoints

kumarjonwal91
New Contributor

Hi Team,

Did anyone tried to upgrade openSSL for all the mac Endpoints with the current version 3.0.7? I wanted to upgrade the same for all mac endpoints which are enrolled with jamf pro as the current or the older versions are detected with the vulnerability.

Any help will be highly appreciated.

1 REPLY 1

CSCC-JS
Contributor II

I use a custom Extension attribute (not sure who the original person to credit this).

This targets a file of your choice and will result in "Not installed" or report back the specific date/time of the file.
You can then make smart groups that targets "Not Installed" or a specific date of the file.
This assumes the unique date/time information correlates to a specific version of the file

 

 

#!/bin/sh

testFile="/path/file"

if [ -f "${testFile}" ] ; then
result=$( /bin/date -j -f "%s" "$(/usr/bin/stat -f "%m" $testFile)" "+%Y-%m-%d %T" )
else
echo "<result>Not Installed</result>"
fi

echo "<result>$result</result>"

exit 0