iBeacon Limitations

mdfoster
New Contributor II

I just got our first iBeacon and was trying to deploy a simple webclip using the limitations scope as was described in the What's new video. But every time the mobile configuration policy is deployed, it is again immediately removed. Anyone else able to use iBeacons in their environment yet? Any ideas for troubleshooting steps?

1 ACCEPTED SOLUTION

mdfoster
New Contributor II

I finally got it to work. I was reading in this post (https://jamfnation.jamfsoftware.com/discussion.html?id=13976)
that you have to make sure that you are collecting beacon location information, which I was. But another post there by mike.paul mentioned that you need to open Self Service after creating the iBeacon network segment so the iPad will download a list of Beacon locations to look for. So after opening Self Service on the device again and making sure that the device was Capabile and enabled: Bluetooth Low Energy Capability: Capable
Location Services For Self Service Mobile: Enabled It finally worked! Now I just have to remember the steps I used to get it to work...

View solution in original post

12 REPLIES 12

brad
Contributor

Do you actually see the Web Clip for a moment? I am guessing you did, but do you have it scoped to All or some amount of devices if you are using the iBeacon as a limitation.

-Brad

mdfoster
New Contributor II

Yes, I see the Web Clip appear and immediately disappear. Same in the Management history. I tried scoping it both to all devices as well as just my test device. Same results. Here's the log from my device's Management commands history:

Certificate List    Today at 5:57 PM
Profile List    Today at 5:57 PM
Remove Configuration Profile Webclip limitation by iBeacon  Today at 5:57 PM
Profile List    Today at 5:57 PM
Install Configuration Profile Webclip limitation by iBeacon Today at 5:57 PM

What is the profile list doing that's causing it to immediately remove it?

brad
Contributor

Weird. Is there any delay at all from installing to removing. I see from the log it all happens in the same minute. From what I understand there should be at least a 20 second delay from leaving an iBeacon region to removal of a profile.

mdfoster
New Contributor II

not really, it pops up on the home screen, then immediately disappears. Same goes for the profile when I watch it in the settings.

dwenger
New Contributor III

I've tried the workflow described above and am seeing the same results. The web clip appears for no more than a second before being removed.

mdfoster
New Contributor II

Looks like iBeacons are still not quite ready for prime time...

dwenger
New Contributor III

Haven't had a chance to test this in my environment yet, but was informed that iBeacon monitoring needs to be enabled in the Inventory Collection area(s) of settings of the JSS for this to properly function.

ckostovny
New Contributor II

Anybody have any luck with this issue? I'm experiencing the same behavior in my test device's management history. I haven't actually watched the screen of the device and seen the web clip appear. I did enable beacon monitoring on mobile device inventory collection.

dwenger
New Contributor III

It sounds like D-007880 is related to the issue we are seeing. Hopefully we see a fix before too long. Looking forward to putting this feature to use.

sadamson
New Contributor

Will iBeacons work with a MacBook Air (2012 or newer) that is powered on but the lid is closed? I'm working on something to try and get a inventory of laptops in a cart or cabinet by putting a iBeacon in the cabinet/cart and when the laptop is in range (in the cart) it SHOULD update inventory.

I'm using a search inventory using:
is in iBeacon Region CART
AND
member of group CART

I'd also like to have a reverse search for the WRONG laptop in a cart:
is in iBeacon Region CART
AND
NOT member of group CART

My other question is could I have a smart cart group that depending if the iBeacon sees the laptop it switches between groups? I'm trying to work out a "dashboard" that would should all the carts and quickly see if they are in the proper cart at the end of the school day. Thoughts, experiences or suggestions, let me know
Scott

nelsonmiller
New Contributor

How did you set your policy up so that your iPads/iPhones get this web clip? I am using the Two Canoes iBeacons (have tried the 100 and 200 series) and nothing seems to happen.

mdfoster
New Contributor II

I finally got it to work. I was reading in this post (https://jamfnation.jamfsoftware.com/discussion.html?id=13976)
that you have to make sure that you are collecting beacon location information, which I was. But another post there by mike.paul mentioned that you need to open Self Service after creating the iBeacon network segment so the iPad will download a list of Beacon locations to look for. So after opening Self Service on the device again and making sure that the device was Capabile and enabled: Bluetooth Low Energy Capability: Capable
Location Services For Self Service Mobile: Enabled It finally worked! Now I just have to remember the steps I used to get it to work...

View solution in original post