Jamf Connect/Login user migration

KyleEricson
Valued Contributor II

I'm working with a customer and they want to use Jamf Login/Connect. I got this all deployed and setup. The issue I see is since this creates a new user account on their Mac what can we do with the old account data. They want all the data that was on the old local account. Is there a script that would be good to run so they can migrate data over? This is a deployment with out MDM yet.

Read My Blog: https://www.ericsontech.com
10 REPLIES 10

merps
Contributor III

You should be able to use the migrate flag:

defaults write /Library/Preferences/com.jamf.connect.login.plist Migrate -bool TRUE

defaults write /Library/Preferences/com.jamf.connect.login.plist MigrateUsersHide -array "localadmin" "managementaccount"

When set, the user should be able to log in, and then get presented with a list of accounts that are already on the system.

Here's a link to the documentation for these preferences.

KyleEricson
Valued Contributor II

This is only for Okta.

Migrate
Allow local accounts to be migrated to Okta-based accounts.
<key>Migrate</key>
<false/>

Read My Blog: https://www.ericsontech.com

KyleEricson
Valued Contributor II

Just tested and works with Azure thanks.

Read My Blog: https://www.ericsontech.com

dswitmer
New Contributor III

Does anyone know how to format this in the plist that is delivered by the configuration profile? I can't find this mentioned in the documentation. Where did you find this?

KyleEricson
Valued Contributor II

look here and here

Read My Blog: https://www.ericsontech.com

dswitmer
New Contributor III

Has anyone else been able to get this to work with Azure. Jamf support tells me it's not supposed to work but as we can see above it is working for some.

adhuston
Contributor

I haven't been able to get this to work under version 1.1.2.

michaeloswell
New Contributor II

I've used the Migrate flag with Azure and it works ok.

The problem I'm having is if you log out/restart afterwards and try and log in with the azure window the next time it loops back. Logging in with local auth is fine but kind of defeats the point of migrating.

I've since removed the Migrate flag for a test and it looks like it doesn't do it any more. Is this a known bug or is there a good way to avoid it?

tn57gs
New Contributor

As you can see below I have used "Migrate" key in the payload and still after successful AzureAD sign-in its not presenting a window with list of existing local users for me choose and map. 

Greenshot 2024-01-10 23.47.02.pngGreenshot 2024-01-10 23.47.58.png 

please assist

tn57gs
New Contributor

According to logs from this location /private/tmp/jamf_login.log it seems like JC is throwing error as shown below and I suspect migrate key isn't working as expected. please assist if you are aware of this issue. 

JamfConnect-ErrorLogs.png