Jamf Pro using significant memory

KyleEricson
Valued Contributor

Does anyone else get this all the time in Jamf Pro console with Safari?
75259402666f442e939bc2509c68bae7


Hire me as an independent contractor.
20 REPLIES 20

taylorducharme
New Contributor III

yes

mainelysteve
Valued Contributor II

@kericson Yes. I use Safari for most tasks and having that banner constantly coming and going while in the dashboard is annoying to say the least.

canopimp
New Contributor III

I too am getting that message now that we have upgraded to 10.21 last week. I just looked and Safari is using almost 2gb of RAM.

mapurcel
Contributor II

I just started getting this after upgrading to 10.22

lukasz_slodziak
New Contributor III

Hi, I’m a Product Owner at Jamf. The team I work with has researched this issue and we have some fixes that should help address these struggles. They will be introduced in one of the upcoming Jamf Pro releases.

However, while researching the root cause of these memory issues with Safari 13.1, we noticed a significant and lasting improvement in browser performance once we completed a full cache/data clearing of Safari. This removes all your browser data, but gets the browser to a state similar to a fresh install. I realize the advice to clear your cache is right there next to “have you turned it off and on again,” but our experience shows there’s real gain to be had. If you’re ready to try it out, here is a site with good step by step directions to clear your cache https://www.macworld.co.uk/how-to/mac-software/clear-safari-cache-3496193/. We have followed all of these and achieved better results.

KyleEricson
Valued Contributor

Thanks @lukasz.slodziak It's good to know that in future versions this will be fixed. I have tried the clear cache method as well and sometimes it does help. Would you say it's best to clear after ever Jamf Pro update?


Hire me as an independent contractor.

lukasz_slodziak
New Contributor III

Hey @kericson, I believe it depends on your experiences so far: if you’ve seen improvement each time you cleared the cache and you are not missing any of the data, then it’s worth a try, but the issue we’ve seen with Safari 13.1 should be alleviated with the first complete cache and data wipe of the browser. If the memory popup persists, it’s likely caused by a problem in Jamf Pro and we will attempt to address that.

snowfox
Contributor III

@lukasz-slodziak Yep I've seen this (this week) (using Jamf Pro 10.21) and I can see what is happening. It happens across all browsers. I mainly use Firefox and I was doing a lot of policy editing recently. While doing so the jamf web page loading was getting slower and slower the more policies I editied until it was taking 10 seconds+ for the page to load. When I checked Firefox's memory usage it was sitting at 9Gb ram just for Jamf Pro. I only had 1 tab open. (Using Firefox 79.0 64-bit on macOS.) When I deleted my cache, (and closed and re-opened the browser) the ram usage went back to 121mb.

Every time you view a webpage of the Jamf Pro interface (policies page for example), the entire page gets loaded into the browsers cache and stays there permenantly until you clear your browser cache. My browser is set to auto delete everything upon browser close. I do that and Jamf Pro web page loading goes back to appearing in 1 second instead of the spinning wheel of death. So, the more of the Jamf Pro interface web pages you view in 1 session, the bigger the amount of ram is used up by the browser and the slower and slower things get.

I'll just chuck in that Firefox 79.0 ( & the Developer edition 79b6 and 80b1) no longer allow you to add and remove a pkg from a policy. It just sits there and spins the wheel but never updates the page. It worked ok in Firefox 78.0.2 but from 79.0 onwards I have to use an alternative browser. Chromium and webkit based browsers work fine. But Firefox is now broken whatever change Mozilla has done to it. I switched over to the Safari browser to edit pkgs in my policies and I started seeing the same message as above - this page is using a lot of memory. So Safari is doing the same thing as Firefox.

Deleting the browser cache puts the Jamf Pro webpage usage back to 121Mb and it slowly increases exponentially again the more you browse the server. This has been my experience over the past week.

snowfox
Contributor III

Add - Firefox no longer lets you add Scripts to policies now either O_o

jmbwell
New Contributor II

Is there a clear reason to completely reset the browser instead of simply removing the data associated with affected sites?

tomt
Valued Contributor

Have been seeing the memory error in Safari for a while now. Hopefully Jamf can figure out what changed and fix it.

tomt
Valued Contributor

Still seeing this error and it is happening on brand new systems as well as my daily driver.

@lukasz.slodziak Has there been any work done to resolve this issue?

lukasz_slodziak
New Contributor III

Hey! @jmbwell we have been focusing our efforts on troubleshooting and repairing Jamf Pro, so we did not dig deeply into which specific steps in the work around solution were most beneficial. Based on our internal testing efforts, we were able to confirm that following all the steps to completely wipe all data was useful in resolving the issues we’re seeing.

@tomt During our investigation into Jamf Pro code, we found the culprit wasn’t a single root cause we could repair. Instead we found a number of smaller issues joining forces together to manifest as a larger memory problem. We have tweaked our codebase in a number of ways to address all these and the problem no longer presents itself in our testing environments. Please tune in to the release of our upcoming beta, 10.25.0. We are very much looking forward to your feedback.

Thanks!

kgam
Contributor

Happy to find this in the release notes for 10.25.:
[PI-008552] Fixed an issue that caused Jamf Pro to use an excessive amount of memory when viewed using Safari.

Looking forward to testing the new release.

dsardaczuk
New Contributor III

In our Jamf Pro cloud world this incident still exist with jamf version 10.25.1-t1602899070 and safari Version 14.0 (15610.1.28.1.9, 15610)

lukasz_slodziak
New Contributor III

Hey @dsardaczuk! I am bummed to hear you’re still experiencing this issue. With the release of Jamf Pro 10.25.0 the engineering team has resolved all root causes for these type of struggles that we were able to identify. If you’re still seeing issues it sounds like there might be another root cause to dig into. Please be sure the cache has been completely cleared recently and then if you continue to see it I’d recommend filing a Support ticket. I would prefer to have you in direct contact with fast communication channels. I love Jamf Nation but unfortunately my response times vary a lot! I don’t want to drop any balls with regards to getting you the help you need and determining the new issues as fast as possible.

To help Support start digging in please be sure to tell them that you’ve upgraded and cleared your cache. I’d also recommend helping them focus the triage by sharing what Jamf Pro pages you have spent the most time on when you experienced the error. This won’t necessarily be the page you see it on. It could be a page you have spent a significant amount of time on and then moved somewhere else. It’s likely an area is causing the memory issue to build up, but it manifests after you navigate elsewhere.

Once again, thank you for helping us dig in and make the product better.

KyleEricson
Valued Contributor

I see the same issue even with brand new Jamf Pro instances. @lukasz.slodziak I can try to keep track where I see it most.


Hire me as an independent contractor.

dsardaczuk
New Contributor III

Hey @lukasz.slodziak
Today it worked fine without notification of memory usage in safari. but some days later, it is there again.
and still lots of logouts from jamf when switching from dash to config or policy or other items. regards
Dirk

dsardaczuk
New Contributor III

Here it is again.
see image
e8a4fa1d357a431d833e08bebf252d3e

howie_isaacks
Valued Contributor

This is still happening. I'm getting really sick of seeing this while working in Jamf Pro. I WILL NOT switch to a different browser. My MacBook Pro has 32GB of RAM and my iMac has 24GB. I have more than enough installed memory for Safari to use a lot if needed. Every other site that I use when I am working does not do this. It's only happening with Jamf Pro.
99212951054843a497a1fbde2d75b55a