Jamf reporting App present on machine, actual machine doesn't have the app installed.

JimmyMouse1
New Contributor II

Hello,

I'm running into an issue with our MacOS Big Sur rollout for our company in that a smart computer group I scoped out has the criteria of "Application Title has Install macOS Big Sur.app" but some of the computers that are in this group don't actually have the application, Install macOS Big Sur.app, on their machine.

 

I was wondering what could possibly cause this issue? When I check the computers in Jamf under the Applications tab in the Inventory, the application, Install macOS Big Sur.app, will show up there. However, when I remote into the actual machine I don't see the application at all. 

Any help that can be provided would be greatly appreciated. Thank you for your time.

5 REPLIES 5

mm2270
Legendary Contributor II

Has inventory been updated recently on these Macs? Smart Computer Groups use the last inventory data stored for computers in the database as the basis for the group membership. If the Macs in question have not submitted updated inventory since the Install macOS Big Sur.app was removed from them, then Jamf Pro can only go by what it last knew about when determining group membership.

JimmyMouse1
New Contributor II

Thanks for your reply. For one of the machines that was showing the app being installed in the Jamf Pro client but not on the actual Mac machine, I remoted into it and ran the sudo jamf recon and sudo jamf policy commands to have it check-in.

After running these commands, the computer in Jamf Pro still showed it had the macOS Big Sur.app being installed but the machine itself did not show this application anywhere on the system.

mm2270
Legendary Contributor II

What path does Jamf Pro show for the macOS Big Sur.app when you view it in a computer record? Is it possible it's somewhere in a non standard path on the system where you're just not seeing it?

Because if not, I don't have a good explanation for why Jamf would be reporting it as being installed. It has to be there somewhere if it's picking it up. Either that or something is screwy with the database in your Jamf instance.

JimmyMouse1
New Contributor II

Install macOS Big Sur.app
Version 16.6.01
/Applications/Install macOS Big Sur.app

This is the path that I am seeing on the Computer when I check in Jamf inventory for the computer under Applications. We SSH'ed in and couldn't see the path/folder that Jamf was referencing as well as established a remote connection and poked around ourselves and couldn't find it but Jamf is reporting it as being installed on the machine. 

mm2270
Legendary Contributor II

Well, that's really odd. It's saying it's in the main Applications folder, so not at all tucked away somewhere weird. I honestly don't know why Jamf Pro would be reporting it as being there.

The only other thing I can suggest, and this is a little strange, but did you run something like ls -al /Applications in Terminal to see if it was somehow invisible in the Finder? I kind of doubt that, but worth a shot if not already checked.