Just had a Linux SUS/Netboot VM built have you seen this error?

NealIV
Contributor

sudo: no tty present and no askpass program specified

If so why and how did you fix it? I had them rebuild the Linux server and ran the netboot sus appliance but still no go. I can log into the web server but if I try to make a change a save such as the network time server, it does not save and it gives me the sudo: no tty present and no askpass program specified error.

1 ACCEPTED SOLUTION

calumhunter
Contributor III

NetSUS is pretty average, sorry JAMF but its horrible.

@NeallV what services do you need? Netboot? software updates?

Reposado and Margarita works great. For NetBoot BSDPy is also fantastic.

Look into using Docker, you could have a netboot server and reposado with margarita server up and running in about 15 minutes.

I use CentOS minimal as a base, install docker then pull down my bsdpy and reposado images and run them, piece of cake.

View solution in original post

10 REPLIES 10

Josh_S
Contributor III

Did you make sure to run the installer as root/sudo or does your organization limit who can modify the /etc/sudoers file? That error is generated when the application attempts to escalate privileges using sudo, but sudo is still setup to ask for a password in order to run the command. The sudoers file should have a line which indicates that some limited commands can be run without prompting for password.

hkabik
Valued Contributor

We ran into this error setting up a RHEL NetSUS server at my last organization. Sadly we never worked out what was causing it and it ended up shutting down the entire project moving us back onto a physical OS X Server.

I wish I had better news, but it confounded our Linux engineers and our JAMF support guys. As I'm just about to start the SAME project at a new organization I will be watching this thread closely though! Good luck, hope someone else out there has an answer for this.

imperatives
New Contributor III

Same here...."sudo: no tty present and no askpass program specified" was displayed in all of the fields. We worked with JAMF on numerous occasions to get NetSUS installed and running properly on RHEL, but dropped the project after they were unable to provide us with a solution. The JAMF engineers we worked with stated that the NetSUS product was "broken" and they are looked into fixing it. This was several months ago, but it doesn't appear like there have been any updates. If you do find a solution please share.

NealIV
Contributor

Yikes! Crap, that doesn't sound good at all. The JAMF engineers are having a hard time with this and our Linux guys at work can't figure it out either. I don't want to go to a physical box if I can help it.

calumhunter
Contributor III

NetSUS is pretty average, sorry JAMF but its horrible.

@NeallV what services do you need? Netboot? software updates?

Reposado and Margarita works great. For NetBoot BSDPy is also fantastic.

Look into using Docker, you could have a netboot server and reposado with margarita server up and running in about 15 minutes.

I use CentOS minimal as a base, install docker then pull down my bsdpy and reposado images and run them, piece of cake.

jbarnes
New Contributor

For once I have something useful to contribute to jamfnation:

For the "sudo: sorry, you must have a tty to run sudo" all over the web interface for the JAMF Netboot Server, the fix is to comment out the "requiretty" line in the /etc/sudoers file. I'm using CentOS, not the appliance, but I imagine it would be similar?

Javier_R
New Contributor

I am running RHEL and am having this same issue. I have tried the above solutions but none work. Does anyone have any other solutions?

Dalmatian
Contributor

I have the same issue this morning,

added the following line back in sudoer then it's running

www-data ALL=(ALL) NOPASSWD: /bin/sh scripts/adminHelper.sh *

dilan
New Contributor III

Hey Guys,

We are running RHEL and the fix for us was to do as @Dalmatian except use the user "apache". The lines below are added to your suoders file.

apache ALL=(ALL) NOPASSWD: /bin/sh scripts/adminHelper.sh *

And a safer option if you're distributing your sudoers file:

apache hostname=(ALL) NOPASSWD: /bin/sh scripts/adminHelper.sh *

The adminHelper script uses the "apache" user instead of the "www-data" user as it does with Ubuntu.

@hkabik , hopefully this is useful information for you.

rmcdonald
New Contributor III

Thanks @Dalmatian, this solution helped me out today.