Laptop stuck in loop after Remote Lock

New Contributor

We had a macbook pro go missing so I pushed out a remote lock. We later recovered the laptop (about a week after), and the laptop prompted me to enter the 6 digit security code. I entered the code and the laptop went to the Apple logo with a grey progress bar underneath. By the time the progress bar is completed, the laptop shuts down. Turning it on starts the same process again.

I have tried restarting, holding down the power button for the power lights to flash, but it continues to loop. It doesn't seem to netboot either. Any suggestions? JSS 9.22 and a macbook pro running 10.8


Contributor II

I had this problem too, however it was on a new Haswell Retina with the forked image. My findings seemed to lead to the recovery partition being an incorrect version relating to the OS. If you need data from the device I was able to from a fresh start clear the PRAM and target boot the mac. It asked for the 6 digit code, but once entered the next screen it went target disk mode. I was then able to connect it to another mac, unlock the drive (as we use file vault), and pull the data off. Once the data is off you can partition the drive. You may have to option boot and install from a bootable installer of your choice OS. To prevent this from happening on other macs, I would install the 10.8.5 combo update as I believe it also fixes and updates the recovery partition to be compatible with the OS This can be scoped and pushed via Casper. If you use Filevault, I wouldn't recommend blowing away and deploying a fresh Recovery Partition as I believe Filevault key information is stored inside it. Hope this helps, and its at least a start.

New Contributor

mojo21221 you saved me! My situation is not identical but wanted to share in case it could help somebody out. (That said, I'm new here and I'm inexperienced in JAMF compared to most of you. Any feedback to help me learn is always appreciated).

I remote locked a machine when a user was terminated. Now 90 days later I'm repurposing the machine and it turns out that lock codes were somehow wiped from our management history logs (any insight here would be great... but that's another topic). We contacted Apple for the firmware unlock procedures as we've done before. After unlocking the firmware through Apple's protocol I was now getting past the main firmware lock screen, but the machine kept booting to the JAMF lock screen, prompting me for a 6-digit lock code. A simple PRAM reset removed this layer. I don't fully understand it, but it worked! Thanks!